cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Advocate I
Advocate I

Power App Components not working with Global variables used with Input properties

Problem:  Creating a new component with Input parameters.  When using the component and setting the custom input parameter with a variable, the value passes thru, as the variable is reset, the control does not update with the variable.  Replication Steps are recorded  in the 2 min 20 sec recording showing the issue.
https://www.pbeck.co.uk/2020/02/power-apps-component-potential-bug.html

Initial Hypothesis: I have a large Power App project that uses this technique a lot.  The global variable were working until Fri 14 Feb 2020.  I believe the Power Apps version has been updated and is causing the issue.  I have tried the work on multiple environments and tenants.  It is happening across them all.

20 REPLIES 20
Highlighted

@jwillems 

I would typically agree with you, but this is why components are off by default and you must go to Advanced Settings and turn them on under the 'Experimental Features' menu where it states they may change, break, or disappear at any time.

Microsoft PowerApps is on the edge of innovation and I tend to believe everyone here are still relatively early adopters. To innovate, you must breath things.

Highlighted
Regular Visitor

The issue is resolved - Microsoft has released a new Power Apps build version today 3.20022.17 and the issue is 100% resolved 🙂

View solution in original post

Highlighted

This is great news!

 

Unfortunately this update hasn't hit my account yet. Hopefully it will soon!

Highlighted

Hi @JroderickMP @paulbeck1 @jwillems ,

A fix had gone out earlier today. Can you let us know if the issue is resolved for you?

View solution in original post

Both releases today are working correctly
Highlighted

I am on version 3.20021.29 and the issue is still there for me. What version has the fix? I don't think the update has hit my account yet...

Highlighted

3.20022.17 version works for me, got it in the uk morning today
Highlighted

Version 3.20022.19.
It isn't working!!!!!!!!!!!!!!

Highlighted

3.20021.29 has the fix. Please describe your exact situation so we can determine whether the fix is expected to address it.

Highlighted

There was a problem with the rollout to preview.create.powerapps.com, so if you are seeing version 3.20022.19, it may not work yet. The rollout to preview should be complete later today. Apologies for the inconvenience.

View solution in original post

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors
Users online (13,229)