cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
landonjochim
Resolver I
Resolver I

Power Apps Bug - Setting Text property in Data Table with Hyperlink, will refuse to show Text when Published

Hey all,

 

Experienced a weird bug within a Power Apps Data Table today. My table has a column where I would be placing a link for a user to click on. I did not want the column to show the long URL, so I hard set the Text property for that column. When in the Power Apps editor, it looked like everything was fine. However, it would refuse to publish this and in the deployed application, it would show whatever the columns value was. This was only fixed with a super basic If statement. Then all worked fine... weird.

 

Below is the app in the Power Apps editor. Everything looks fine. I then Publish the app. 

landonjochim_0-1629751817781.png

Properties of the "Link" column.

landonjochim_1-1629751824590.png

 

Below is what the app looks like when I run it. The Text of "Link to item" is completely ignored and it shows whatever the value of that column is. 

landonjochim_2-1629751921889.png

What do I have to do to resolve this? I place in a basic If statement like the one below. Republish

landonjochim_3-1629752056031.png

 

Then it works just fine.. 

 

landonjochim_5-1629752125672.png

 

Just weird. I hope Microsoft fixes this bug or am I losing it and can someone set me straight??

 

Thanks.

3 REPLIES 3
PowerAddict
Super User
Super User

Hi @landonjochim

 

I could reproduce this behavior. Definitely seems super weird. Curious to see if someone from Microsoft can look into this and create a bug. 

 

---
If you like this reply, please give kudos (Thumbs Up). And if this solves your problem, please mark this reply as a solution by selecting Accept as Solution. This makes it easier for others to find answers to similar questions. 

 

Thanks!

Hardit Bhatia

Microsoft Business Applications MVP

Microsoft Certified Trainer MCT

Blog | Twitter | LinkedIn | Facebook | YouTube  |  Email

pajkuscz
New Member

The bug is really annoying. There is workaround - create collection with same data and addColumn with static text "Link to Item" and action onSelect to open link

gabibalaban
Super User
Super User

@landonjochim ,

Set a context/global variable with the text you want to appear, in this case "Link to item" and set the Column  - Text property to this variable. I will work !

 

Hope it helps !

Helpful resources

Announcements
PA_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

secondImage

Power Apps Community Call

Please join us on Wednesday, October 20th, at 8a PDT. Come and learn from our amazing speakers!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Welcome Super Users.jpg

Super User Season 2

Congratulations, the new Super User Season 2 for 2021 has started!

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Top Solution Authors
Top Kudoed Authors
Users online (1,596)