cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
AengusHeaney
Microsoft
Microsoft

Power Apps Test Studio Feedback discussion thread

We recently launched the new Power Apps Test Studio to help you build end-to-end tests for your Canvas apps. You can read more about it in this blog post. As you use the tool, we’d love to hear your feedback, so we can prioritize the next set of improvements, any features that are missing, or any of the current behaviors that may not be ideal.What kinds of tests are you writing? Is there anything that is too hard to understand, and that we could make easier? This community post will be used to consolidate all feedback on the tool. You can also access this post directly from the "Provide Feedback" link in the Test Studio.

62 REPLIES 62
EricLott
Super User
Super User

I'm not seeing the Tests pane under Advanced Tools even after enabling the Formula-level-Error management feature.

Hi Eric, we are currently rolling out the feature and Americas is the last region to get the deployment. Is this is the region you are in? The feature should be there soon. 

Yes, that's my region. Thank you, can't wait to try it out.

EricLott
Super User
Super User

@AengusHeaney 

Would it be possible (for debugging purposes) to show the passive "steps" after recording a case such as OnVisible and OnStart actions?

Interested to hear more on your scenario. Eric. Monitor, available in the Advanced tools panel will give you this granular debug capabilities if you are trying to isolate a problem. 

londontoholland
Frequent Visitor

Hey, I'm not able to get it to work.

 

I created a simple test case which clicks on a link on the home page to navigate to another screen.

 

When I run the test case, the app loads but nothing happens. The spinny wheel next to the step just spins but the link isn't opened.

 

I do have quite a bit of code in the app's OnStart function (which transforms some data - a loading message is displayed for about 5 seconds to the user). Not sure if this has anything to do with it?

 

EDIT: Ok, this is very strange. If I navigate to another tab in my browser and then click back onto the PowerApps test tab, the test advances to the next step. I can repeat this behaviour. It won't advance until I navigate away and then back again

 

Thanks,

 

Scott

John742
Frequent Visitor

The navigation bar in our app is a component and as such does not work with the test studio. I attempted to insert a Navigate(screen) into the steps, but it does not seem to work. Is the Navigate() function unsupported in the test lab? Anyone else able to make this work?

Yes, we do not support components yet. The navigate function is supported - are you getting any error? 

That is really strange behaviour - what happens if you copy the play link and play it outside the studio? The OnStart function should not intefere with the test. 

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

Power Apps Community Call

Monthly Power Apps Community Call

Did you miss the call?? Check out the Power Apps Community Call here!

secondImage

Experience what’s next for Power Apps

See the latest Power Apps innovations, updates, and demos from the Microsoft Business Applications Launch Event.

Power Platform ISV STudio

Power Platform ISV Studio

ISV Studio is the go-to Power Platform destination for ISV’s to monitor & manage applications post-AppSource publish.

Top Solution Authors
Top Kudoed Authors
Users online (70,758)