Showing results for 
Search instead for 
Did you mean: 

Power Apps Test Studio Feedback discussion thread

We recently launched the new Power Apps Test Studio to help you build end-to-end tests for your Canvas apps. You can read more about it in this blog post. As you use the tool, we’d love to hear your feedback, so we can prioritize the next set of improvements, any features that are missing, or any of the current behaviors that may not be ideal.What kinds of tests are you writing? Is there anything that is too hard to understand, and that we could make easier? This community post will be used to consolidate all feedback on the tool. You can also access this post directly from the "Provide Feedback" link in the Test Studio.


Hi Laura,


How did you automated the test studio in Azure Pipeline. I'm facing difficulties while doing so. Is any any blog/docs on the same.

Hi @VikashMahato ,

I used these guides.

It was fiddly to set up at first, but once its running, you just have to paste in your new test script urls into the GitHub step 2 - Create Test URL.json

Ive managed to get the results feeding into a couple of Dataverse tables, which I would hope long term I can present for analysis/reporting in PowerBI, but I am a little way off that yet!

Advocate I
Advocate I

I know the blog post from January 2020 states the work on "controls in components" is not yet complete (which was confirmed by the recording error below).  I'm using a component with just a gallery that changes screens for navigation, which was the reason I searched for and found the Test Studio. 

Is there a roadmap or update scheduled for the Test Studio?





Thanks you for sharing the information. I have successfully setup the pipeline everything seems working fine but only "Make teams call" is getting exported, the app created by me are not getting exported.


I can see the solution getting exported but not the apps. The same process works if I do it manually by exporting and importing the solution.

Hello @johndpalmsd

 We are still working on Test Studio roadmap, but we don't currently have a specific timeline for supporting components yet. Will keep you posted as we have new updates. 



Regular Visitor


i got an error about telemetry when i run my test using azure devops tools

tests autamatically fail 


that is the log



Frequent Visitor

When writing test suites of over 50 actions the form for editing the actions cannot keep focus.  For example, I am on item #30 and click on 31 and suddenly I am at item 78.  Then I scroll back to the 25 to 35 range and the UI jumps again when I set focus on a line.  If I scroll up and down some random # of times the line numbers that work change but the behavior still persists.  I am using Google Chrome at 100% zoom scale.  The app is a canvas app not in a solution but when adding it to a solution the behavior is equally difficult to use.  Animated GIF attached showing behavior

Regular Visitor

Hi All,


I'm encountering a error when attempting to save my tests within test studio. The error message simply reads "This test didn't save properly. Please try again." as shown in the attached screenshot. Things that I have tried so far:

  • Attempting to save an empty test suite and test case
  • Recording several test steps and then attempting to save
  • Ensuring the 'formula-level error management' setting is on, saving and publishing the app
  • Logging out and logging back in
  • Using a private/incognito browser

So far none of the above have made any difference and the error remains.


Note that creating a new canvas app and creating tests for it allows me to save as expected without any error.


Has anyone seen this error and/or have any other suggestions regarding how to get it working?





Hi Kevin, We are aware of this issue and have completed a fix that is entering the final stage of a release train.  It should start rolling out across North American regions next week for 'frequent' environments.  As a temporary workaround, you could use to edit this app which already has the fix.  Thanks for the feedback!




Hi, I have the same issue as Kevin. When I create an app and add a test everything works fine but when I open the app/tests later and try to save a new test, I get the error "This test didn't save properly. Please try again". I tried using the preview editor but the issue persists. 


Any ideas what I can do to fix this?



Helpful resources

UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Top Kudoed Authors
Users online (2,655)