cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
larry_ourique
Helper I
Helper I

Power Apps and Android

Hi

 

I have a Power App checklist that I built from a SharePoint list and I have a couple of users who are on Android devices receiving the following error.

 

dcbe3dc3-5d55-4356-bb5e-337770c7eb92.png

Has anyone else encountered this?

 

Thanks

Larry 

1 ACCEPTED SOLUTION

Accepted Solutions
v-xida-msft
Community Support
Community Support

Hi @larry_ourique ,

Does the error message show up when you run your app in web browser?

Have you taken a try to run your app in iOS device? Same issue occurs?

 

Based on the issue that you mentioned, I have made a test on my side, and don't have the issue that you mentioned. Please check if the version of your PowerApps Mobile App in your Android device has been upgrade to the latest version, if not, please consider upgrade it to the latest version, then try your app again, check if the issue is solved.

 

Also please consider turn on the "Formula-level error management" option and turn off the "Explicit column selection" option within Advanced settings of App settings of your app, then re-publish your app, then try it again within your Android device, check if the issue is fixed.

 

If the issue still exists, please consider re-create a new connection to your SP list from your app, then re-publish your app, check if the issue still exists.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

7 REPLIES 7
PowerAddict
Super User II
Super User II

Hi, can you please provide some more info like is it just these users who are using Andriod who are experiencing this issue? It doesn't seem like from the error message but I dont want to assume anything.

---
If you like this reply, please give kudos. And if this solves your problem, please accept this reply as the solution. Thanks!

Hardit Bhatia
https://thepoweraddict.com

Currently the only users experiencing this error are Android users.  It doesn't prevent them from entering information, but the error does pop up.

 

Thank you

A few more questions:

1. When does this error occur? Is it on the loading of a screen? If so, what controls exist on the screen? Is it the 1st screen of the app?

2. Does it occur on every screen? Is it when the user types something in the combo box search? Does it repeat when the user goes to a diff screen and comes back to this screen?

---
If you like this reply, please give kudos. And if this solves your problem, please accept this reply as the solution. Thanks!

Hardit Bhatia
https://thepoweraddict.com

1.  The error occurs when you attempt to create a new record.  When a user selects the + to create new.

2.  The app only has two screens.  It only appears on the second screen..

 

Thank you

Larry

v-xida-msft
Community Support
Community Support

Hi @larry_ourique ,

Does the error message show up when you run your app in web browser?

Have you taken a try to run your app in iOS device? Same issue occurs?

 

Based on the issue that you mentioned, I have made a test on my side, and don't have the issue that you mentioned. Please check if the version of your PowerApps Mobile App in your Android device has been upgrade to the latest version, if not, please consider upgrade it to the latest version, then try your app again, check if the issue is solved.

 

Also please consider turn on the "Formula-level error management" option and turn off the "Explicit column selection" option within Advanced settings of App settings of your app, then re-publish your app, then try it again within your Android device, check if the issue is fixed.

 

If the issue still exists, please consider re-create a new connection to your SP list from your app, then re-publish your app, check if the issue still exists.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Thank you for all the information.  

 

I turned on the "Formula-level error management" option and made sure the "Explicit column selection" option was off.  I also went ahead and re-published the app and it seemed to fix the issue. 

 

Thank you

Larry

Hi @larry_ourique ,

Have you solved your problem?

 

If you have solved your problem, please consider go ahead to click "Accept as Solution" to identify this thread has been solved.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

secondImage

Demo Extravaganza is Back!

We are excited to announce that Demo Extravaganza for 2021 has started!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Power Apps June 2021

June Power Apps Community Call

Did you miss the call? Check out the recording here!

Top Solution Authors
Top Kudoed Authors
Users online (68,049)