cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
PrernaK
New Member

Power Automate Flow not Triggering OnSuccess of Form

Hi All,

I have a scenario where I needed a simple flow with trigger as PowerApps V2 to trigger on success of form submission. I used monitor tool to test that the flow run is not triggering when I submit a new form. But when I edit the same item of form then the flow triggers from Onsuccess itself. Any suggestions? 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Alex_10
Memorable Member
Memorable Member

@PrernaK 

 

I think flow is not triggered if passing parameters are blank.

 

what if you try specify your flow run with lastSubmit as parameters or hardcoded values if needed? 

Eg. yourFlow.Run(YourParam1: yourForm.LastSubmit.yourDataColumn1, YourParam2: yourForm.LastSubmit.yourDataColumn2, etc)

View solution in original post

2 REPLIES 2
Alex_10
Memorable Member
Memorable Member

@PrernaK 

 

I think flow is not triggered if passing parameters are blank.

 

what if you try specify your flow run with lastSubmit as parameters or hardcoded values if needed? 

Eg. yourFlow.Run(YourParam1: yourForm.LastSubmit.yourDataColumn1, YourParam2: yourForm.LastSubmit.yourDataColumn2, etc)

PrernaK
New Member

Thanks for your help Alex. That was the case. The form was resetting before the flow could run. Hence, the parameters was passing as blank. As a workaround I stored the information in another control outside of my form and then ran the flow with the control values as input. 

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

365 EduCon 768x460.png

Microsoft 365 EduCon

Join us for two optional days of workshops and a 3-day conference, you can choose from over 130 sessions in multiple tracks and 25 workshops.

Users online (2,504)