cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
v-antal
Microsoft
Microsoft

Power BI tile not showing in canvas app (The report shown in this tile doesn't exist or you don't have permission to view it)

I have added a PBI tile a long time ago that was working fine until last week. Regarding access, I'm the owner of both the Powerapps and the PBI report/group. Suddenly the tile is showing the following message (The report shown in this tile doesn't exist or you don't have permission to view it).

 

Please let me know if there was a change on the PBI-Powerapps integration or how can I solve this

 

Thank you.

46 REPLIES 46
shrijabajpai
Helper I
Helper I

I am also getting issue

shrijabajpai
Helper I
Helper I

Hi, I am also facing the same issue. Any update

Is this issue fixed for you or you are still getting? I have also started getting this error in all my apps which were working fine since last 6 months.

cb-2014
New Member

I am having the same issue. My app had a PowerBI tile that was working fine. The tile was a pinned report, but now I've started getting this error. I own the entire PowerBI and PowerApp workspace so it's not an access issue and I can see everything within PowerBI, it seems to just be the connection between the two.

 

I even tried to start a blank canvas and a new PowerBI workspace and it still didn't work.

shrijabajpai
Helper I
Helper I

Has anyone created support ticket with Microsoft yet? I have created but no respond from them yet. 

PaulBI
Resolver I
Resolver I

Yeah just had the same thing happen to me.  This had been working for months if not years on other apps.  Of course I had people start to use a new app yesterday.  Come in this morning and all live page pins on all apps are showing this error message.  Any help on how to resolve would be fantastic.

artFRC
Frequent Visitor

I'm also experiencing this issue today following months of working correctly. All tiles from dashboards (from two separate reports) failing to load within one Power App.

 

The only change I have made since the power app was last working is re-publishing one of the two reports from Power BI desktop - but that hasn't broken things in the past.

 

By the sounds of it someone at MS is breaking things, not anything on our end. Wonder if it's isolated to this feature or broader issues.

 

Grateful my app isn't business-critical and I haven't recently launched it - fingers crossed this is resolved soon for @PaulBI's sake!

MattyJ_09
Advocate IV
Advocate IV

I'm having this issue also.  Does anyone know if Microsoft has an ETA as to when it will be resolved?

Still not working for me. Did you contact Microsoft? 

Anonymous
Not applicable

I'm having this issue also for all my apps. Any update?

Helpful resources

Announcements
PA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

This training provides practical hands-on experience in creating Power Apps solutions in a full-day of instructor-led App creation workshop.

Microsoft Build 768x460.png

Microsoft Build is May 24-26. Have you registered yet?

Come together to explore latest innovations in code and application development—and gain insights from experts from around the world.

May UG Leader Call Carousel 768x460.png

What difference can a User Group make for you?

At the monthly call, connect with other leaders and find out how community makes your experience even better.

Top Solution Authors
Top Kudoed Authors
Users online (2,953)