cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
langsem
Post Patron
Post Patron

Power apps dont send images to azure

I have an power apps and a flow that sends some images to the azure blob storage, It seems that sometimes it works and sometimes it dont work. "funny" thing its that it dont say anything when it fails.. So my flow its all succeed upon the recent flow runs.. Why is that? Cant azure blob storage handle decent amount of request, is it limited somehow ? 

4 REPLIES 4
sb92
Helper I
Helper I

Hi langsem. How are you sending the images, have you encoded URI and sent it as a code or a file?

Sent as an file 

sb92
Helper I
Helper I

In power automate, for the file content have you tried doing the base64 to binary expression? And passing the URI of the image to it ?

ClearCollect(colBase64;DropColumns(AddColumns(imageCollection;"Base64";Mid(JSON(Image;JSONFormat.IncludeBinaryData);25;Len(JSON(Image;JSONFormat.IncludeBinaryData))-25));"Image"));;
Set(JsonCol;JSON(colBase64;JSONFormat.IncludeBinaryData));; ForAll(AzureImgs; AzureBlobStorage.CreateFile("pictures";Name ;Image));; ClearCollect(AzureImgs;Blank());;

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

365 EduCon 768x460.png

Microsoft 365 EduCon

Join us for two optional days of workshops and a 3-day conference, you can choose from over 130 sessions in multiple tracks and 25 workshops.

Users online (3,895)