cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
cooltechie
Helper IV
Helper IV

Power apps performance very slow in internet explorer

Hello,

 

I have a power apps form where I customized a SharePoint list form and all I have on the form is about 15-20 fields and then one additional data source such as "Office365 users".

 

The form performance is okay in Chrome but is very slow in Internet Explorer. Is this known behaviour? Please advise.

 

Thanks.

1 ACCEPTED SOLUTION

Accepted Solutions

Hey,

 

Just wondering if you experience the same in Edge?

 

Could you please collect a performance trace for me to take a look at?

 

To do that, please open internet explorer and go to the settings and select F12 developer tools (or you can just hit F12)

Go to the performance tab and start recording.

Load your form.

Once your form is done loading, save the trace and send it to me. (Feel free to send it to me in a private message)

 

Thanks!

View solution in original post

5 REPLIES 5
cherie
Power Apps
Power Apps

Hey,

 

Does your form happen to have a lot of combo boxes? We do have a known issue where in internet explorer the performance gets worse the more combo boxes there are. We are working on a fix for this.

 

Could you also share your session id so we could take a look to see if there are any other things that might be contributing to this? To get your session id, please run the form and then hit alt + right click on the form.

 

Thanks

Cherie

here you go:

 

Session ID: b2ea7806-23f6-4f9f-b5e7-b35d2afb051b
PowerApps 3.18114.16

Hey,

 

Just wondering if you experience the same in Edge?

 

Could you please collect a performance trace for me to take a look at?

 

To do that, please open internet explorer and go to the settings and select F12 developer tools (or you can just hit F12)

Go to the performance tab and start recording.

Load your form.

Once your form is done loading, save the trace and send it to me. (Feel free to send it to me in a private message)

 

Thanks!

View solution in original post

Anonymous
Not applicable

hi @cooltechie thank you for posting this thread and thank you @cherie for your help so far!

 

@cooltechie Are you still experiencing this issue in Internet Explorer?

 

@Anonymous

cooltechie
Helper IV
Helper IV

Edge works great!!

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Top Kudoed Authors
Users online (2,960)