cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
New Member

PowerAPPs Attachments don't work properly

I have a PowerAPP based on a Sharepoint List with an attachment field. My APP has three screens:

  • the list screen; where I can choose a single item so opening
  • the browse screen. I can select the Edit button and so I open
  • the edit screen where, in the data form, I can add an attachment.

When I push the button "Done" I submit the form and the screen closes itself, coming back properly to the browse screen.  (With your suggestion) now in the Browse screen the attachment appears (and into the sharepoint list you can find it).

But if I come back to the Edit Screen the attachment doesn't appear. I have to come back to the list screen, chose an other item then come back again to the previous one and now I can find into the Edit Screen.

After this second action the attachment is finally viewed also into the Browse screen.

Is this a bug that I can solve in some way? Thank you

3 REPLIES 3
Highlighted
Community Support
Community Support

Re: PowerAPPs Attachments don't work properly

Hi @ailedac ,

Based on the issue that you mentioned, I also made a test on my side, and don't have the issue that you mentioned.

 

Please make sure the Item property of the Edit form is set to following formula:

Gallery1.Selected     /* <-- Gallery1 represents the Gallery in your List screen */

 

In addition, please also consider take a try with the following workaround:

1. set the OnSelect property of the Gallery or the ">" icon (Navigate icon, click it to navigate from List screen to Browse screen) within the Gallery in your List screen to following:

Set(CurrentItem, Gallery1.Selected);   /* <-- Gallery1 represents the Gallery control in your List Screen */
Navigate(BrowseScreen, ScreenTransition.None)

2. Set the Item property of the Display form in your Browse Screen to following:

CurrentItem

set the OnSelect property of the "Edit" icon within your Browse screen to following:

ResetForm(EditForm1);
EditForm(EditForm1);
Navigate(EditScreen, ScreenTransition.None)

3. Within your Edit screen, set the Item property of the Edit form (EditForm1) to following:

CurrentItem

Please consider take a try with above solution, then check if the issue is solved.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Community Champion
Community Champion

Re: PowerAPPs Attachments don't work properly

Hi @ailedac how are you progressing with this? Was the above reply helpful?

 

@TopShelf-MSFT 

Highlighted
New Member

Re: PowerAPPs Attachments don't work properly

This week I’m working at other projects. I will be back next week! Thank you

Helpful resources

Announcements
secondImage

Demo-Extravaganza 2020

Check out these cool Power Apps & vote on your favorite!

secondImage

Community Highlights

Check out whats happening in Power Apps

secondImage

Community User Group Member Badges

FIll out a quick form to claim your community user group member badge today!

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors
Users online (7,798)