cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted

PowerApp - Dynamics 365 JSON Error message

Hi, 

 

In a flow I just tried retrieving some customer data by entering a very simple get records action that worked all the time.

Unfortunately, this time it does not work anymore as I permanently receive the following error. 

'The template language expression 'json(decodeBase64(triggerOutputs().headers['X-MS-APIM-Tokens']))['$connections']['shared_dynamicsax']['connectionId']' cannot be evaluated because property 'shared_dynamicsax' doesn't exist, available properties are ''. 

Has somebody seen a similar error message?

 

What I find very interesting is that everything works fine if I manually start and test the flow. If I start it through the PowerApp, I receive the error, which does not make sense to me. 

 

Would be great if somebody can help. 

 

Many thanks and best regards, 

 

Ludwig

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Hi,

I finally got that fixed.

The trick is that the connection between powerapps and flow should only be made at the very end.

That is, one should not make changes to the flow after e.g. a powerapps button that triggers this flow has been established.

After recreating the flow everything works like a charm.

Yet, I find it a bit difficult that I had to rebuild my flow multiple times until I noticed how this works.

But now, everything is fine Man Happy

Many thanks for the feedback and best regards,

Ludwig

View solution in original post

2 REPLIES 2
Highlighted
Community Support
Community Support

Hi @lreinhard7,

 

Would you please share the detailed configuration of the flow and app? Some screenshots would be even better.

 

Regards,

Mona

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted

Hi,

I finally got that fixed.

The trick is that the connection between powerapps and flow should only be made at the very end.

That is, one should not make changes to the flow after e.g. a powerapps button that triggers this flow has been established.

After recreating the flow everything works like a charm.

Yet, I find it a bit difficult that I had to rebuild my flow multiple times until I noticed how this works.

But now, everything is fine Man Happy

Many thanks for the feedback and best regards,

Ludwig

View solution in original post

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Community Highlights

Community Highlights

Check out the Power Platform Community Highlights

Top Solution Authors
Top Kudoed Authors
Users online (11,880)