cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
AndrewG-AU
Regular Visitor

PowerApp Portal liquid "entities" not working

Hi,

I'm trying to display the basic information of account on a page, but this syntax not working - the account variable is always null.

 

{% assign account = entities.account[<account record id goes here>] %}
{% if account %}
{{ account.name }} ({{ account.statecode.label }})
{% endif %}

Not supported yet??

1 ACCEPTED SOLUTION

Accepted Solutions
AndrewG-AU
Regular Visitor

Re: PowerApp Portal liquid "entities" not working

SOLVED!

 

The issue was with permissions. This is how to fix it:

  1. Go to "Entity Permissions" in the portal management app, Security group
  2. Add New, specify the CDS entity you are trying to access, scope - Global
  3. Save
  4. Then on the saved entity permission in the "Web Roles" section add the roles you want to have access (or all roles)
  5. The liquid record lookup as in the previous step works!

If this would help someone.

View solution in original post

1 REPLY 1
AndrewG-AU
Regular Visitor

Re: PowerApp Portal liquid "entities" not working

SOLVED!

 

The issue was with permissions. This is how to fix it:

  1. Go to "Entity Permissions" in the portal management app, Security group
  2. Add New, specify the CDS entity you are trying to access, scope - Global
  3. Save
  4. Then on the saved entity permission in the "Web Roles" section add the roles you want to have access (or all roles)
  5. The liquid record lookup as in the previous step works!

If this would help someone.

View solution in original post

Helpful resources

Announcements
secondImage

Community User Group Member Badges

FIll out a quick form to claim your community user group member badge today!

firstImage

New Ranks and Rank Icons released on April 21!

The time has come: We are finally able to share more details on the brand-new ranks coming to the Power Apps Community!

Top Solution Authors
Top Kudoed Authors
Users online (7,636)