cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

PowerApp does not refresh on iPhone

It takes a while for the new app to refresh on my iPhone. I published a new version of an app but when I go to my iPhone, I just see a blank screen. How can I fix this?

2 ACCEPTED SOLUTIONS

Accepted Solutions
Highlighted
Super User III
Super User III

@fvc226
Unfortunately, all we can do is wait for Microsoft to fix this. I suggest you create a support ticket and raise your concerns.

I have had this issue too.   It began occurring when many people started to work from home due to coronavirus.  Microsoft has been slowing down the time it takes to see changes reflected in other Office 365 apps (see: SharePoint).  PowerApps is likely not an exception to this.


---
Please click "Accept as Solution" if my post answered your question so that others may find it more quickly. If you found this post helpful consider giving it a "Thumbs Up."

View solution in original post

Highlighted

Thanks - My apologies on this one.  I had forgotten I did a save as and created a new app. I was trying to open the old one each time which was never changed.

 

 

View solution in original post

4 REPLIES 4
Highlighted
Super User III
Super User III

@fvc226
Unfortunately, all we can do is wait for Microsoft to fix this. I suggest you create a support ticket and raise your concerns.

I have had this issue too.   It began occurring when many people started to work from home due to coronavirus.  Microsoft has been slowing down the time it takes to see changes reflected in other Office 365 apps (see: SharePoint).  PowerApps is likely not an exception to this.


---
Please click "Accept as Solution" if my post answered your question so that others may find it more quickly. If you found this post helpful consider giving it a "Thumbs Up."

View solution in original post

Highlighted

This is shocking. I have completely removed the App and then reinstalled powerapps and the problem persists.  Is this getting teh priority it needs to have?

Highlighted

I went to the specific app, hit "Edit", then went to the "View" tab. I then clicked on "Data Sources", clicked on the three dots next to the table/dataset (...) and hit refresh. This seems to work for me. 

Highlighted

Thanks - My apologies on this one.  I had forgotten I did a save as and created a new app. I was trying to open the old one each time which was never changed.

 

 

View solution in original post

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Community Highlights

Community Highlights

Check out the Power Platform Community Highlights

Top Solution Authors
Top Kudoed Authors
Users online (6,484)