cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
krishant007
Frequent Visitor

PowerApps Attachments Images and Documents Dont Upload Together

Hi everyone

I was wondering if there is a known bug or if anyone else is having this issue. I am working with the Attachment control for PowerApps. I have built a custom form which allows users to add attachments to the list item in SharePoint. I don't have any issues with uploading 1 or more images at the same time. The images are attached fine as expected. However, when I try to attach an image AND a document (word or pdf or excel), only 1 attachment comes through instead of all of them. 

Here are a couple of screenshots which might help explain.

 

 

Scenario 1

Uploading 2 images to the form

Uploading 2 images as attachmentsUploading 2 images as attachments

 

Both images show up when I open the form again after saving

 

Both images show up in attachments when I open the form backBoth images show up in attachments when I open the form back

 

Both images are showing under attachments for the item

 

Attachment shows 2 items after saving formAttachment shows 2 items after saving form

============================================

 

Scenario 2

Uploading an image and a document at the same time

 

Uploading an image and a document at the same timeUploading an image and a document at the same time

 

Only the document shows up after saving the form and re-opening.

 

Only the document shows up in the form when I open the item againOnly the document shows up in the form when I open the item again

 

Only the document is shown as attached to the item.

 

Only the document is showing as attachment to the item.Only the document is showing as attachment to the item.

===================================

I am not sure if this is a known issue, or if there is a workaround available. So far, I am thinking to just allow images to be uploaded and not documents.

 

Thank you

4 REPLIES 4
WarrenBelz
Super User III
Super User III

Hi @krishant007 ,

This question has been posted many times before and you are doing nothing wrong - Power Apps Attachments controls simply do not allow uploading of more than one file at a time. 

 

Please click Accept as solution if my post helped you solve your issue. This will help others find it more readily. It also closes the item. If the content was useful in other ways, please consider giving it Thumbs Up.

v-xida-msft
Community Support
Community Support

Hi @krishant007 ,

Do you mean that the PDF file and the picture file could not be uploaded at same time?

 

Based on the needs that you mentioned, I have made a test on my side, and don't have the issue that you mentioned. The Screenshot as below:

8.JPG

 

9.JPG

 

Please consider rename the GIF file as 'harrypotter.gif', and then attach the GIF file and the PDF file to one Item again, then check if the issue is solved.

 

Also please check if the size of the GIF file you attached in your app is exceed the default maximum file limit in Attachments -- 10 MB. Please check the following known limits with the Attachments control:

https://docs.microsoft.com/en-us/powerapps/maker/canvas-apps/controls/control-attachments#limitation...

 

Please consider take a try to change the MaxAttachmentSize property of the Attachments control in your Edit form to following:

50

and then check if the issue is fixed.

 

If the issue still exists, please consider re-generate a new app based on your SP List, then check if the same issue also occurs. You could also consider submit an assisted support ticket through the following link:

https://powerapps.microsoft.com/en-us/support/pro

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Thanks @v-xida-msft . I tried to rename the files and attach them again and I got some sporadic behaviour. I attached 2 images and a pdf this time, and the PDF and 1 image were attached, but the other image did not come through.

The behaviour is quite weird. I am trying to do multiple tests to see if there is a pattern.

Hi @krishant007 ,

Have you taken a try re-generating a new canvas app based on your SP List? Same issue still exists?

 

Currently, I could not reproduce your issue on my side, the Attachments control works well on my side. Please try to re-generating a new canvas app based on your SP List, then check if same issue would occur.

 

If the issue still exists, please consider submit an assisted support ticket for further help through the following link:
https://powerapps.microsoft.com/en-us/support/pro

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

Power Query PA Forum 768x460.png

Check it out!

Did you know that you can visit the Power Query Forum in Power BI and now Power Apps

V3_PVA CAmpaign Carousel.png

Community Challenge - Giveaways!

Participate in the Power Virtual Agents Community Challenge

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Top Solution Authors
Top Kudoed Authors
Users online (3,594)