cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
panterra
Advocate III
Advocate III

PowerApps Build 2.0.791 - 2.0.795 - There was a Problem Loading Your Data

I have published builds of our PowerApp using 2.0.791 and 2.0.795 and started getting an error in the stock splash screen. 

 

This error was not present on builds relesaed with PowerApps 2.0.762.  I belive I have isolated the issue to the app's OnStart event (more details below).  

 

 

Problem Loading Data.png

 

This exact code is working fine on builds published 2.0.762.  However, this code is generating errors in build 2.0.791.  When I remove this code and publish it using build 2.0.762, the error goes away.  

 

Has anyone seen similar issues?  Or does anyone from the community / product team have any ideas? 

 

I tried to republish using an older version of the studio referenced here, but am unable to open our Development environment using it. 

 

 

Clear(collSessionAudio);
LoadData(collSessionAudio, "ocollSessionAudio", true);
LoadData(collPlansMaster, "ocollPlansMaster", true);
Clear(collPreferences);
LoadData(collPreferences, "ocollPreferences", true);
If(CountRows(collPreferences) > 0, Set(searchFilterVal, LookUp(collPreferences, myFilter<>"", myFilter) ), Set(searchFilterVal, ""));

 

 

30 REPLIES 30

I just tested this in Version 3.18043.21 (iOS). 

 

I believe this or an earlier release has addressed the issue. 

 

Please note, I needed to actually Save / Save and Publish a build of the app in this PowerApps version for the error to go away.

 

Thanks,

Sean

 

 

Helpful resources

Announcements
Microsoft 365 Conference – December 6-8, 2022

Microsoft 365 Conference – December 6-8, 2022

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

Top Solution Authors
Top Kudoed Authors
Users online (1,557)