cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
SuzanneG
Frequent Visitor

PowerApps Connection to Business Central (On-Premise) using OData Web services

I am trying to create a new connection in PowerApps to our Business Central (on-premise) using Odata Web services. I am replacing the localhost with the external public IP address in the URL that I got from IT so that it looks like the following - http://99.999.99.999:7048/BC140/OData/Company('XYZCompany') After submitting my credentials I get the following error from Powerapps - status 503 Service Unavailable. When I plug the exact same address into any browser, I am prompted for my credentials and successfully connected to the service. This leads me to believe, that the problem is with PowerApps, because clearly the service is not unavailable nor are my credentials incorrect. Is anyone else having this problem? I would love to hear how you solved it, or maybe it is totally a PowerApps bug.

3 REPLIES 3
trese8
Microsoft
Microsoft

What kind of authentication are you using?  

 

Have you tried using the Business Central connector - https://docs.microsoft.com/en-us/connectors/dynamicssmbonprem/

I am using Windows Authentication and am using the build in Business Central (On-premise) connector. 

MarcVettorel
Regular Visitor

Hi,

we got the same issue. Did you solve the problem?

Helpful resources

Announcements
Power Apps News & Annoucements carousel

Power Apps News & Announcements

Keep up to date with current events and community announcements in the Power Apps community.

Power Apps Community Blog Carousel

Power Apps Community Blog

Check out the latest Community Blog from the community!

Top Solution Authors
Top Kudoed Authors
Users online (5,047)