cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
dbirdRN
New Member

PowerApps DisplayMode Not Working as Before

Recently in PowerApps the ability to disable a button based on Blank fields is not working.

Formula I use in many apps that is not working is:

If(IsBlank(DataCardValue#), Disabled, Edit)

I often have several fields which I separate with || and this has always worked in the past to require fields be filled for the submit button to enable. This not currently working in PowerApps, just noticed this today. Did something change?

2 ACCEPTED SOLUTIONS

Accepted Solutions

This was working for me just a week ago, the problem just showed up.  I will include a couple of screen shots.  The button is outside the form.

dbirdRN_1-1643214763888.png

 

If(IsBlank(DataCardValue6.Text),Disabled,Edit)

The Birthdate field (fake date) is a text field which is filled; however, the submit button does not enable.  This is a new problem that just started.  I have many application I use this same workflow and have never had a problem before now.

View solution in original post

As I said, there is a recent bug that is causing issues trying to read values from controls inside a form when you are outside the form.  If the buttons are outside the form then I suspect that is the problem you are having.  The first report I saw of this bug was about a week ago.  I'm personally not able to reproduce it, but Microsoft has.  For a test add a label to the form and see if you can see the value of the control you are setting disabled on.  I suspect it will be blank.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

View solution in original post

6 REPLIES 6
Pstork1
Dual Super User
Dual Super User

You should be using DataCardValue#.Text to specify the property you are testing rather than just the control. I suspect in the past it defaulted to the main property and things have been tightened.  Since IsBlank only works with strings you really should be specifying the actual value you are testing.

If(IsBlank(DataCardValue#.Text), Disabled, Edit)

 



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

I just tried the solution your recommended; however, I have have a Text box filled yet the submit button remains disabled.

I just tested and its still working for me.  Is the button inside or outside the form?  There is a known bug at the moment where values of controls inside forms don't show their values outside the form.  That might also cause the symptom you are seeing.  The workaround seems to be saving the value as a variable in the OnChange property of the control.  Then use the variable outside the form.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

This was working for me just a week ago, the problem just showed up.  I will include a couple of screen shots.  The button is outside the form.

dbirdRN_1-1643214763888.png

 

If(IsBlank(DataCardValue6.Text),Disabled,Edit)

The Birthdate field (fake date) is a text field which is filled; however, the submit button does not enable.  This is a new problem that just started.  I have many application I use this same workflow and have never had a problem before now.

As I said, there is a recent bug that is causing issues trying to read values from controls inside a form when you are outside the form.  If the buttons are outside the form then I suspect that is the problem you are having.  The first report I saw of this bug was about a week ago.  I'm personally not able to reproduce it, but Microsoft has.  For a test add a label to the form and see if you can see the value of the control you are setting disabled on.  I suspect it will be blank.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.
dbirdRN
New Member

By including the button inside the Form, this worked.  I have many forms with similar DisplayMode use, I hope the issues if fixed.  The current form is working and I have not checked if this affected any other forms.

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

Power Platform Call June 2022 768x460.png

Power Platform Community Call

Join us for the next call on June 15, 2022 at 8am PDT.

PA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

This training provides practical hands-on experience in creating Power Apps solutions in a full-day of instructor-led App creation workshop.

PA.JPG

New Release Planning Portal (Preview)

Check out our new release planning portal, an interactive way to plan and prepare for upcoming features in Power Platform.

Top Solution Authors
Top Kudoed Authors
Users online (2,209)