cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

PowerApps Form Not Storing Data or Attachments

For the past few weeks, when users submit a custom PowerApps form bound to a SharePoint list, data entered doesn't appear when you open the form and may or may not not show up on the list. Email notifications sent through a flow show all the correct information. Documents attached to the form also don't come through. In PowerApps, some of the fields (though not all, I believe), showed an error: "data source supplied to the function is invalid." Editing, saving, and publishing the form seemed to fix that very briefly, and then it reverted. It also didn't help when I removed the attachments field, saved, published, then added back in, saved, and published.

4 REPLIES 4
Drrickryp
Super User II
Super User II

Hi @Anonymous 

I have encountered something similar in the past.  Removing the datasource and re-connecting it solved the problem for me. 

Anonymous
Not applicable

Thanks, @Drrickryp . Will this mean rebuilding the form--organizing fields, re-adding conditional formatting, etc.? Just don't want to scrap what I have unnecessarily....

Hi @Anonymous 

Not at all.  When you remove the datasources, everything will error but you can ignore that.  Don't worry, everything (forms, galleries, controls, etc. ) will reconnect once you add the datasources back. 

grizmac
Regular Visitor

I had a similar problem due to the datasource links becoming corrupt intermittently(unsure why).  Deleting and re-adding the datasource resolved the issue permanently so far, but save yourself the time of recreating your entire app by following the below:

 

After you delete the original datasource, make sure when you add your new datasource back into the app that you give it the same name as the original datasource so all of the pointers/links automatically reconnect.  If you change the name of the new datasource (often the default names will add or append _x integer values to the end of given names i.e. DataTable becomes DataTable_1) then the pointers will be broken and you will have to edit each property that uses the original datasource name.  I have deleted an existing datasource, re-added it and then modified the 'appended' name to match the original name, without having to update any existing fields that referenced the original datasource name.  I hope this saves you some time.

Helpful resources

Announcements
PA_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

Power Query PA Forum 768x460.png

Check it out!

Did you know that you can visit the Power Query Forum in Power BI and now Power Apps

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

R2 (Green) 768 x 460px.png

Microsoft Dynamics 365 & Power Platform User Professionals

DynamicsCon is a FREE, 4 half-day virtual learning experience for 11,000+ Microsoft Business Application users and professionals.

Users online (2,615)