cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
jsnyce
Level: Powered On

PowerApps Forms - Strange errors on submit

Hello everybody,
I have a strange issue that I've been driving myself crazy to figure out... I'm in the process of building an app for our Marketing department, where end users can submit certain requests from our marketing department. I have the app all built out and started doing some testing on my own before I gave it to the business to test. I came across a very strange validation error that is popping up on just two random fields but no others. Neither of these fields are required from the data source or in the app itself. The other strange thing is they are both text fields but the error message is describing "Value must be between 1 and 1048576" as if it was a number field. Anyone have any ideas as to what could be throwing this error? I am completely out of ideas to try on my end!

Thank you in advance for any help you can provide!

 

FormError1.PNGFormError2.PNG

7 REPLIES 7
Super User
Super User

Re: PowerApps Forms - Strange errors on submit

Normally those errors come from the data source. What is your data source and does the error happen everytime you submit the form without filling in the fields. If you put some text in those fields does it except it or does it give you the same error?



--------------------------------------------------------------------------------
If this post helps answer your question, please click on “Accept as Solution” to help other members find it more quickly. If you thought this post was helpful, please give it a Thumbs Up.
jsnyce
Level: Powered On

Re: PowerApps Forms - Strange errors on submit

That's what I thought too, but reviewed everything from the source and could not find any required data that was missing.  I'm using the CDS for a Dynamics365 entity. I did just attempt to put some data in those fields and it did seem to accept it, but it looks like there is something else causing an error that is preventing me from submitting the form.  I guess there isn't a way of determining what exactly is preventing the submit, is there?

jsnyce
Level: Powered On

Re: PowerApps Forms - Strange errors on submit

I figured out what was going on with one of the fields. It's now just down to two mutiline text boxes.  There is nothing requried from the source or the app itself.  Still just throws that "value must be between 1 and [x]".  If I put text in them it will allow the SubmitForm to run; however, ideally there are times where I would want to be able to submit the form without all of the multiline text boxes to be populated. Anyone have any ideas as to why that error message is being thrown? Thanks!

Super User
Super User

Re: PowerApps Forms - Strange errors on submit

Have you tried using the Validate() to help debug the issue? 

 

https://docs.microsoft.com/en-us/powerapps/maker/canvas-apps/functions/function-validate



--------------------------------------------------------------------------------
If this post helps answer your question, please click on “Accept as Solution” to help other members find it more quickly. If you thought this post was helpful, please give it a Thumbs Up.
BenDenBlanken
Level: Powered On

Re: PowerApps Forms - Strange errors on submit

A colleague of mine had the same issue. Did you managed to fix this?

 

We found out that a ResetForm before calling a NewForm fixed our issue. Like this:

ResetForm(CreateTaskForm); NewForm(CreateTaskForm); Navigate(CreateTask, Fade)

It feels like a workaround though.
jsnyce
Level: Powered On

Re: PowerApps Forms - Strange errors on submit

Interesting...  I will have to give that a try! It does feel like a work around, but at this point I frankly don't care, I just want the thing to work! Thanks for the tip!

Lars4
Level: Powered On

Re: PowerApps Forms - Strange errors on submit

I have the same problem and had opened a ticket. 

Meanwhile, Microsoft support comfirmed it being a known issue. Patch is expected to come on 7th Nov.

 

Consider to turn off preview feature switch "Improve data source experience and Common Data Service views". Afterwards, that issue does not appear anymore. (Well, having another problem with edit form now... but that's not the topic) 

 

Helpful resources

Announcements
thirdimage

New Badges

Check it out!

thirdimage

Power Apps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

Top Solution Authors
Top Kudoed Authors
Users online (6,458)