cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
poweruserjim
New Member

PowerApps Gallery not pulling all row data from sql table

URGENT 

I'm struggling with figuring out why data is missing from my gallery. My gallery is shown below coming from sql with the following filter on it. The row count is in the top left 507 rows, I have increased delegation limit to 2000 yet still have issues with 507 rows. It sometimes loads the top 26 rows but nothing after that. The column in which are coming from sql are the 6 from the left, rest of them are just measurements based off those columns.

poweruserjim_0-1609968542404.png

poweruserjim_1-1609968686382.png

 

1 ACCEPTED SOLUTION

Accepted Solutions

Thanks for the ideas, this actually helped me solve it! By copying the data to a DataTable I was able to narrow down the issue to the gallery as all of the data was there on the DataTable. I then copied the gallery to another screen on a limb and all the data was there. Don't know exactly what the issue was but seems to have fixed itself!

 

Thank you!

View solution in original post

3 REPLIES 3
Drrickryp
Super User
Super User

Hi @poweruserjim 

The functions Sort() and Filter() are 100% delegatable and should result in a full table of values.  As a test, could you use that simple formula as the Items property of a DataTable control and see if it is truncated or complete and all 6 columns are represented?  On another thought, is the JobIndex field text or number?  It may be that some of the values are text and some are numbers.  You could troubleshoot that possibility by trying this in your formula

Sort(Filter(your_dbo, JobIndex*1 = 1,JTDHours, Descending)

 

Thanks for the ideas, this actually helped me solve it! By copying the data to a DataTable I was able to narrow down the issue to the gallery as all of the data was there on the DataTable. I then copied the gallery to another screen on a limb and all the data was there. Don't know exactly what the issue was but seems to have fixed itself!

 

Thank you!

View solution in original post

Drrickryp
Super User
Super User

@poweruserjim 

Congratulations on Solving your own issue.  Glad to help.  To troubleshoot these kinds of issues, I like to simplify the problem by using a datatable.

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Top Kudoed Authors
Users online (1,992)