cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
sambuka42
Regular Visitor

PowerApps Org Browser - getting error

New to Powerapps.   I am trying to customize the Org Browser.     I have 2 issues.

 

1.   getting this error on the Iphone (triangles on the build)  

The service returned an error: Office365Users!DirectReports: The method 'DirectReports' has an invalid value for parameter 'userId'
 
the app works perfect, it is just the error message on the phone that i am trying to get rid of
 
2.  on the startup screen - the name of the app is left aligned.   trying to get center aligned.
 
not sure if this is my session id:  Session ID: 80ad5a4c-8b21-8e53-8f02-525685c9a46a
PowerApps 2.0.680
16 REPLIES 16

That did it, Thanks. got down to my last issue - our president does not report to anyone so I'm getting an error saying that. App still works but anytime he is selected we see this error message.

 

any ideas?

Anonymous
Not applicable

Worked perfectly for me, thank  you! Smiley Happy

Anonymous
Not applicable

I am having a similar problem with the Browse Org app. All works great but I keep getting an error message. I believe this is due to blank photos in some of the user profiles. My latest function -- which still errors out is listed below: 

Function.JPG

 

What have I got wrong? 

It looks like you have a syntax error. Could you hover over the red squiggly to see what it says?

 

Are you trying to use a condition to determine what the image should be? (I don't actually see an "if" statement there.)

 

Syntax:

If(logical test, true statement, false statement)

 

let me know if that helps,

Audrie

Hi,

 

I'm having the same problem on the iOS app, works fine in Windows.  I've tried to use the code discussed here:

If(!IsBlank(First(Employee).Id), Office365Users.DirectReports(First(Employee).Id)) for the TextBox1_14 (Organisation Screen) for Direct Reports but I still get the error.

 

Did anyone solve this and if so could they help with some newbie steps please?

Thanks!

 

 

Did you got a fix for that?

Yamaha54
Frequent Visitor

I'm not following the solution here.  I'm running the PowerApps Org browser app, works fine until I have an Employee with no Manager listed, then I get the error.  In App Checker, Rectangle3.OnSelect errors:

ClearCollect(
Employee,
Manager
);
Collect(
PreviousEmployee,
Employee
);
If(
!IsBlank(Office365Users.Manager(First(Employee).Id)),
ClearCollect(
Manager,
Office365Users.Manager(First(Employee).Id) --this has a red squiggly line under it in App Checker
)
);
Navigate(
OrganizationScreen,
Fade
)

<p>Office365Users.Manager failed: {
"status": 404,
"message": "No manager found for the specified user.\r\nclientRequestId: 6fc8cf67-e958-4c70-9a2c-61db647cc5c3",
"source": "office365users-wus.azconn-wus.p.azurewebsites.net"
}</p>

 

Could I fix this by updating Active Directory for Manager to 'No Manager' ?

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Welcome Super Users.jpg

Super User Season 2

Congratulations, the new Super User Season 2 for 2021 has started!

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Users online (1,166)