cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
TJL
Regular Visitor

PowerApps Postgres Connection failing for Azure Hosted PostgreSQL, same gateway & DB works for PowerBI

Hi all, 

 

I'm trying to create a PowerApps Connection to an Azure Hosted PostgreSQL Database using an exisiting On Premises Data Gateway. The same Gateway is currently used by PowerBI Pro to connect to the same database on the same server and it works fine.

 

When trying to make the connection via Powerapps Connection screen it fails, saying: Credentials are missing or not valid. inner exception: The credentials provided for the PostgreSQL source are invalid. (Source at servername.postgres.database.azure.com;databasename.) clientRequestId: 

 

Creds have been checked 100 times. 

 

Powerapps can use the same gateway to connect to a non-azure hosted postgres instance that doesn't require the username to be in the username@serverhostname format. 

 

I'm not sure if its a bug with the PowerApps Postgres connector that is in preview or the gateway

 

Looking for ideas, throughts, directions or places to file bugs for PowerApps Connectors

 

TJL

4 REPLIES 4
v-monli-msft
Community Support
Community Support

Hi @TJL ,

 

After some research, it seems that so far there is no document published for PostgresSQL about the connecting steps.

Please check if below thread could help:

https://powerusers.microsoft.com/t5/General-Discussion/Postgres-connection/td-p/63839

 

Regards,

Mona

 

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi Mona, 

 

I have reviewed that documentation but I'm not using ODBC, I'm using NPGSQL (https://www.npgsql.org). The same gateway (using NPGSQL) on same machine works perfectly for PowerBi to connect to Azure Hosted PostgreSQL but not when using the PowerApps connector via the same gateway.

 

I found this documentation: https://docs.microsoft.com/en-us/connectors/postgresql/ ,but under https://docs.microsoft.com/en-us/connectors/postgresql/#creating-a-connection it just refers to entering a username and doesn't mention the format.

 

I think the connector doesn't support usernames in the username@serverhostname format that Azure Hosted PostgreSQL uses or doesn't pass the information correctly to the On Premise gateway. 

 

I can PowerApps connector via the same gateway to connect to a local PostgreSQL instance that doesn't use the username@serverhostname format, but that doesn't help me connect to Azure Hosted PostgreSQL! 😞

 

Anything else you can suggest? Or any one else we can send this to? 

 

Regards,

 

TJL

TJL
Regular Visitor

Poking to see if any one has any ideas about this? 

liambm
New Member

A little late to the party, but I just had the same problem for the last hour. Azure's default config for Postgres enforces SSL, looks like the PowerApps connector doesn't support SSL. If you disable "enforce SSL connection" under "Connection security" in your Azure control panel for the Postgres instance it should work (or it did for me anyway)

Helpful resources

Announcements
PA_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

secondImage

Power Apps Community Call

Please join us on Wednesday, October 20th, at 8a PDT. Come and learn from our amazing speakers!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Welcome Super Users.jpg

Super User Season 2

Congratulations, the new Super User Season 2 for 2021 has started!

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Top Solution Authors
Top Kudoed Authors
Users online (1,584)