cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
DawgPoundMBA
New Member

PowerApps SharePoint List Update Issues (Edit form freeze)

 I posted this in another forum and havent recieved a response.

 

https://powerusers.microsoft.com/t5/Design-Matters/PowerApps-customize-form-loading-New-Yes-Edit-No/...

 

I have created a custom powerapp form for a sharepoint list.  When I create a new item I am able to load the powerapp, save the item, and return to the list no problem.  But if I click on an already existing item and click edit it just says 'getting your data...' and does not go any further.  My sharepoint integration values are as follows:

 

OnNew NewForm('Backflow Test')

 

OnEdit EditForm('Backflow Test')

 

Thoughts?

1 ACCEPTED SOLUTION

Accepted Solutions
charger85
Advocate I
Advocate I

I know this is real late to the party, but I've been having this issue as well and ran across this post to try and find an answer. In my case, I have a separate form on a different screen I am using as my edit form. Turns out the default Item property for the form is blank and needs to have some reference to the selected item before it will load the data.

 

Go to the form properties, click on the advanced tab and enter SharePointIngegration.Selected into the Item property and it should start working.

View solution in original post

11 REPLIES 11
v-monli-msft
Community Support
Community Support

Hi @DawgPoundMBA,

 

Make sure that your custom form's name is exactly 'Backflow Test'. By default it should be "SharePointForm1":

Capture.PNG

 

Please try to remove the form, and readd a new one. Remember to change the Form name in NewForm/EditForm function.

 

Regards,

Mona

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

I believe I already have done what you have suggested.  Note that the New Form works fine.  Here are screen shots:

 

 

Anonymous
Not applicable

Same problem here. My form gets stuck when i click edit. 

Same problem here. Worked fine before and now I get a screen that says Getting your data.... and it goes nowhere

Anonymous
Not applicable

Same problem still exists.

LEGOLumberjack
New Member

I've been having the same problem here -- it worked before but now does not. Has anyone found a solution? Is this a PowerApps bug?

 

*never mind ... the problem was indeed that my EditForm had no Item property set. I used the same Item property as the DetailForm and now it's working.

Hey all,

 

Could you please provide session ids for us to take a look?

 

You can get it from your form by doing Alt + right click.

 

Thanks

Cherie

charger85
Advocate I
Advocate I

I know this is real late to the party, but I've been having this issue as well and ran across this post to try and find an answer. In my case, I have a separate form on a different screen I am using as my edit form. Turns out the default Item property for the form is blank and needs to have some reference to the selected item before it will load the data.

 

Go to the form properties, click on the advanced tab and enter SharePointIngegration.Selected into the Item property and it should start working.

caheynen
Frequent Visitor

Thank you for posting this!  It pointed me in the right direction.  "Items" on my Form was blank, too.  The input to fix it was different though.  

I am using a single Integrated form on a SharePoint list.  My data source is named "CRs."

 

If(IsBlank(SharePointIntegration.Selected) || IsEmpty(SharePointIntegration.Selected),First(CRs),SharePointIntegration.Selected)

Helpful resources

Announcements
Microsoft 365 Conference – December 6-8, 2022

Microsoft 365 Conference – December 6-8, 2022

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

Top Solution Authors
Top Kudoed Authors
Users online (2,619)