cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Rensvd
Frequent Visitor

PowerApps Studio Web Test fails but App works on Phone

Dear,

 

When i test my new app and the Flow it fails when i run the test inside the Powerapps Studio (web)  but when i trigger the flow within the app on my phone it works.

 

Sometimes the tests run propely and after a while it fails everytime on the same step.

 

Does someone have the same experience? there are stories about experiencing the otherway around but i could not find one like mine.

 

thank you in advance.

2 ACCEPTED SOLUTIONS

Accepted Solutions
Super User
Super User

Re: PowerApps Studio Web Test fails but App works on Phone

Hi @Rensvd ,

You might check and see if the version of your app matches the current version being edited. Maybe there is a mismatch between the published version (the one on your phone) and the one being edited. This can happen if you've made changes and clicked "Save" but not "Publish"

1. Go to web.powerapps.com

2. Click Apps

3. Click the 3 dots next to the app in question

4. Click Details

5. Click Versions

Make sure the "Live" version is the one on top.

View solution in original post

Community Support
Community Support

Re: PowerApps Studio Web Test fails but App works on Phone

Hi @Rensvd ,

 

Do you try @seadude 's suggestions and another idea from my side is do you use other tools which could adjusts the current user’s proxy settings, for example Fiddler. 

More information:

https://www.telerik.com/blogs/capturing-traffic-from-.net-services-with-fiddler

 

Hope this could be helpful.

 

Best Regards.

Yumia

 

View solution in original post

3 REPLIES 3
Super User
Super User

Re: PowerApps Studio Web Test fails but App works on Phone

Hi @Rensvd ,

You might check and see if the version of your app matches the current version being edited. Maybe there is a mismatch between the published version (the one on your phone) and the one being edited. This can happen if you've made changes and clicked "Save" but not "Publish"

1. Go to web.powerapps.com

2. Click Apps

3. Click the 3 dots next to the app in question

4. Click Details

5. Click Versions

Make sure the "Live" version is the one on top.

View solution in original post

Community Support
Community Support

Re: PowerApps Studio Web Test fails but App works on Phone

Hi @Rensvd ,

 

Do you try @seadude 's suggestions and another idea from my side is do you use other tools which could adjusts the current user’s proxy settings, for example Fiddler. 

More information:

https://www.telerik.com/blogs/capturing-traffic-from-.net-services-with-fiddler

 

Hope this could be helpful.

 

Best Regards.

Yumia

 

View solution in original post

TopShelf-MSFT Community Champion
Community Champion

Re: PowerApps Studio Web Test fails but App works on Phone

Thanks for posting in the community @Rensvd - can you review the above replies and update the thread if they were helpful? 

 

Thank you,

 

@TopShelf-MSFT 

Helpful resources

Announcements
MBAS Gallery 2020

MBAS Gallery 2020

Watch Microsoft Business Applications Summit sessions on-demand.

firstImage

New Ranks and Rank Icons released on April 21!

The time has come: We are finally able to share more details on the brand-new ranks coming to the Power Apps Community!

Top Solution Authors
Top Kudoed Authors
Users online (7,802)