cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Advocate I
Advocate I

PowerApps Team Flows Returning Service Error for Shared Users

Hello,

 

 

I have 5 flows within an app that have all been shared to the end user. Each time the end user selects the button to run one of them, they receive this error. How can I make it possible for my other users to be able to call the flows (that run stored procedures or send an email) within my app?

 

Service Error.PNG

 

 

 

Below are the images from the flow and the app:

 

 

TeamFlow.PNGApp.PNG

 

13 REPLIES 13
Highlighted
Community Support
Community Support

Hi @brendanmorley86,

 

I just tested to run a team flow from my side, and it works with no errors.

 

To make the Flow to work within the App correctly, you need to add all the users as the Flow owner.

Further, for sharing an App, check the article below:

Share an app in PowerApps

Share app resources

 

Besides, would it be possble for you to share the error details here?

 

Regards,

Michael

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted

Per my images, I have done the sharing and made the user (Dayea) as an owner to each Flow. She still receives the Service Error telling her that she cannot run the Flow. How am I able to debug the app in order to dig into the details of the error?

Highlighted

Any updates?

Highlighted
Advocate II
Advocate II

I am also having this same issue:

https://powerusers.microsoft.com/t5/PowerApps-Forum/Microsoft-Flows-Stored-Procedure/m-p/58788#M2428...

 

I have ensure the user experiencing the error is an owner of the flow.

Highlighted
Anonymous
Not applicable

We are experienceing the same issue. Have you guys found any resolution?

 

Thanks

Highlighted
Helper I
Helper I

Experiencing the same issue today with all our users. Only flow owners are able to execute flows. We've never had to mark our users as owners to be able to run them.

 

I've been in contact with Microsoft and they are digging in.

Highlighted

Same issue here today, many many flow errors and constant red boxes.

Highlighted
Anonymous
Not applicable

I logged the issue with Microsoft on Friday and receive notification over the week end that the issue had been fixed.

And indeed users where able to access flow triggered by apps this morning.

 

Highlighted

I'm still not seeing mine work. Did you have to do anything to your app to make them work? Did you make the users owners of the flows?

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Community Highlights

Community Highlights

Check out the Power Platform Community Highlights

Top Solution Authors
Top Kudoed Authors
Users online (12,561)