cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
NormYoung
Level: Powered On

PowerApps advice needed

Hello All,

 

I am developing a PowerApps front end that will provision SharePoint sites using PowerShell on the back end. The end user selects a site template, provides a site name, owner, members etc and the request is added to a SharePoint list. The end user is then navigated to a progress screen while the provisionsing takes place.

 

The SharePoint list kicks off a Flow to see if the site already exists and updates the list store the "site exists" result. The problem I am having is that the "site exists" result is not visible on the progress screen. I have tried refeshing the data source but I cannot seem to get the result loaded to the progress screen.

 

I'm not sure what commands or approaches are typically used in this situation and would appreciate any advice.

 

Thanks.

 

Norm

1 ACCEPTED SOLUTION

Accepted Solutions
NormYoung
Level: Powered On

Re: PowerApps advice needed

Hi Michael,

 

Thanks for the response and I apologize for the vagueness of my post. 

 

After inserting a new row to the SharePoint list, the Flow is triggered to check for the existance of the site. The subsequent PowerApps screen uses a timer control and "OnTimeEnd" to Refresh the check site result. The no response code from Flow required the "workaround" with timer / refresh.

 

Thanks again.

 

Norm

View solution in original post

2 REPLIES 2
Community Support Team
Community Support Team

Re: PowerApps advice needed

If I understand your situation correctly, here you are trying to work with a SharePoint list in PowerApps to track with the site existance, together with a Flow, right?

 

Currently there is no methods available to get the Flow response back into PowerApps, if the data source has been connected under PowerApps, then you will need to refresh it manually after it has been updated.

 

Adding an idea for your reference:

Flow Error handling inside Powerapps

 

Regards,

Michael

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
NormYoung
Level: Powered On

Re: PowerApps advice needed

Hi Michael,

 

Thanks for the response and I apologize for the vagueness of my post. 

 

After inserting a new row to the SharePoint list, the Flow is triggered to check for the existance of the site. The subsequent PowerApps screen uses a timer control and "OnTimeEnd" to Refresh the check site result. The no response code from Flow required the "workaround" with timer / refresh.

 

Thanks again.

 

Norm

View solution in original post

Helpful resources

Announcements
thirdimage

Power Apps Super User Class of 2020

Check it out!

thirdimage

Power Apps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

SecondImage

Difinity Conference

The largest Power BI, Power Platform, and Data conference in New Zealand

Top Solution Authors
Top Kudoed Authors (Last 30 Days)
Users online (4,522)