cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Advocate I
Advocate I

PowerApps & Embedded Youtube Bugs

Hi,

 

I'm having a nightmare integrating multiple YouTube videos into a PowerApp. The inconsistency of the settings and how the YouTube video respond are making it near impossible to use as required. I need to use YouTube, as the size of the video is larger than the PowerApps file size limits and Stream doesn't have an 'OnEnd' Property. 

 

Issues I am experiencing with PowerApps & YouTube:

 

Show Controls - When you set this to false, PowerApps randomly mutes the video and due to the controls not showing, it's very difficult to un-mute. Keyboard controls however still work when you tab into the video which is what setting show controls to false is trying to prevent as the user can still control the video.

 

DisplayMode.Disabled - The workaround for the above was to set the 'DisplayMode' to disabled which prevented the random muting of videos. However, keyboard controls still work when you use tab so the user can skip the video.

 

TabIndex - Even when set to -1, tab still allows user to get into the video and subsequently use keyboard controls

 

AutoStart - Randomly, 'AutoStart' just stops working for the End User in chrome and they have to click play. But with 'DisplayMode' set to 'Disabled' unless they know how to get into the video through Tab, then the End User cannot do this. 'ShowControls' allows users to press play without the other controls, but then we are back to having random muting. 

 

Keyboard Controls - YouTube's API has the ability to turn off KeyBoard Controls within iFrame, but this is not available. 

 

Closed Caption - YouTube's API allows Closed Captions to be enabled by default, but this setting is missing from PowerApps

 

PowerApps Version: 3.20074.20

Chrome Version:  84.0.4147.125 (Official Build) (64-bit)

 

My deadline for this PowerApp is September 1st and PowerApps is the near perfect solution! Is there anyway at least some of these issues (ShowControls, Tab Index & AutoStart in Chrome) can be fixed so I can use it as required please? 

0 REPLIES 0

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Community Highlights

Community Highlights

Check out the Power Platform Community Highlights

Top Solution Authors
Top Kudoed Authors
Users online (12,899)