cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

PowerApps & Embedded Youtube Bugs

Hi,

 

I'm having a nightmare integrating multiple YouTube videos into a PowerApp. The inconsistency of the settings and how the YouTube video respond are making it near impossible to use as required. I need to use YouTube, as the size of the video is larger than the PowerApps file size limits and Stream doesn't have an 'OnEnd' Property. 

 

Issues I am experiencing with PowerApps & YouTube:

 

Show Controls - When you set this to false, PowerApps randomly mutes the video and due to the controls not showing, it's very difficult to un-mute. Keyboard controls however still work when you tab into the video which is what setting show controls to false is trying to prevent as the user can still control the video.

 

DisplayMode.Disabled - The workaround for the above was to set the 'DisplayMode' to disabled which prevented the random muting of videos. However, keyboard controls still work when you use tab so the user can skip the video.

 

TabIndex - Even when set to -1, tab still allows user to get into the video and subsequently use keyboard controls

 

AutoStart - Randomly, 'AutoStart' just stops working for the End User in chrome and they have to click play. But with 'DisplayMode' set to 'Disabled' unless they know how to get into the video through Tab, then the End User cannot do this. 'ShowControls' allows users to press play without the other controls, but then we are back to having random muting. 

 

Keyboard Controls - YouTube's API has the ability to turn off KeyBoard Controls within iFrame, but this is not available. 

 

Closed Caption - YouTube's API allows Closed Captions to be enabled by default, but this setting is missing from PowerApps

 

PowerApps Version: 3.20074.20

Chrome Version:  84.0.4147.125 (Official Build) (64-bit)

 

My deadline for this PowerApp is September 1st and PowerApps is the near perfect solution! Is there anyway at least some of these issues (ShowControls, Tab Index & AutoStart in Chrome) can be fixed so I can use it as required please? 

6 REPLIES 6
Specoop
Advocate II
Advocate II

Were you able to find any resolution? Thanks!

Anonymous
Not applicable

Not really, I had to botch a fix to work around, something which I still have to do over a year later. 

 

I had to place transparent boxes over the controls so they couldn't be clicked except for play/pause, volume and captions. I then had to do a complicated check using the OnEnd function to ensure the user watched the whole video. Essentially, when the video starts, a timer also starts in the background and when OnEnd triggers it compares the timer with a threshold (I.e. how much of the video I want the user to watch). If the timer is less than the threshold, it boots them back to the beginning of the video, if its over then it progress's. It really not a good solutions.

 

I'm also now having a problem when the Youtube videos aren't triggering the OnEnd function so the user gets stuck! It's infuriating!

Really appreciate the quick reply! I've played around with a little bit of transparent things also - and it hasn't been ideal - there are so many opporunities to really improve this part of PowerApps!

 

I still can't believe Stream doesn't have "On End"...

Anonymous
Not applicable

It could be really good! MS support hasn't been too great, they want me to send the whole app to them but can't due to GDPR restrictions 😕 

 

I know! Stream would have been ideal! I think this will be the last year using PowerApps for this project, too many headaches!

I don't think YouTube is going to work for me (would be ideal, but PowerApps isn't there yet). 

 

The weird thing is that their SampleVideo (when you first add in the Video Control - a 13 second video) does exactly what I want (autoplays perfectly, can hide the moving forwards etc., has On End).

 

I think (emphasis on think) that may be part of Azure Media Control? That would be starting to get outside my limited knowledge, but again, I think that solution would fit my needs the way I'd like it to. Going to also try and upload an MP4 to SharePoint now and see how that feels.

 

Have a good one!

Specoop
Advocate II
Advocate II

Actually...I think SharePoint hosting of mp4 may (emphaisis on may) fit my need...a few quick notes:

1) Autoplay works with Chrome (didn't work for me with YouTube)

2) Limited background distractions (e.g. can't share, can't open in Youtube) - NOTE: This is good for my situation.

3) Has "End On"

4) Still has pause with Show Controls on False.

 

Going to keep testing, but looking ok so far.

Helpful resources

Announcements
Power Platform Call June 2022 768x460.png

Power Platform Community Call

Join us for the next call on August 17, 2022 at 8am PDT.

Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

Users online (1,884)