cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Eirik1337
Advocate I
Advocate I

PowerApps and Flow don't update fields

So my PowerApp trigger an Approval Flow by pressing a button. Both saves data to the same SharePoint list.

My App worked perfectly until I added a column in the List.

I made a new connection to the Flow in PowerApps and added the fields for the form, in the form's "On Sucess", Run() part.

 

Now, in Flow the variables from PowerApps are only showing in SOME of the fields. It's just weird.

My main problem is that now Flow after getting triggered just stops at the Approval part in the flow. Every variable is updated and should work. The Flow status is "Running" and does not give an error message.

Is there anything I missed?  Do I need to make a new Flow everytime I update the SharePoint list?

1 ACCEPTED SOLUTION

Accepted Solutions

I just made the whole Flow from scratch. Took some hours.

I tried making new button, new flow call, new connectors, I covered everything as far as I can see. I think Flow don't really sync that well, too rigid variables. The change in SP list worked fine in PowerApps though.

 

I'm still new to this but I think the best solution is to make everything perfect from the beginning 🙂

 

 

View solution in original post

2 REPLIES 2
v-micsh-msft
Community Support
Community Support

Hi @Eirik1337

"

Is there anything I missed?  Do I need to make a new Flow everytime I update the SharePoint list?

"

I think the issue here is PowerApps button trigger was not updated with the proper SP list schema change.

So the workaround here should be re-building the Flow from the beginning,

 

or just replacing the PowerApps Button with a new one, then select the corresponding variables again.

Start a flow in a canvas App

 

Best regards,

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

I just made the whole Flow from scratch. Took some hours.

I tried making new button, new flow call, new connectors, I covered everything as far as I can see. I think Flow don't really sync that well, too rigid variables. The change in SP list worked fine in PowerApps though.

 

I'm still new to this but I think the best solution is to make everything perfect from the beginning 🙂

 

 

View solution in original post

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Top Kudoed Authors
Users online (2,266)