cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Daniel_Pipe
Advocate I
Advocate I

PowerApps apps don't load on Samsung Galaxy S4 Android 5.01

Apps never make it past the loading screen on multiple Samsung Galaxy S4 devices. 

 

I've created a meeting room door display/walk-up booking app to make use of a cuboard full of these devices and solve meeting room booking mistakes. I've got the custom housings 3D printed and all ready to go however PowerApps doesn't seem to work on Android 5 (the latest available for these devices).

 

The Play Store says that Android 5 is supported. As this app will be permanently displayed, performance is not an issue.

 

Attempted fixes:

Tried Multiple devices

Tried Multiple apps, including official templates

Factory reset device

Uninstall/reinstall PowerApps

Clear cach and app data

Leaving the device for 12+ hours (no error, just stays on app loading screen, doesn't freeze and loading animation continues)

 

Session ID: 106f0cd2-0fa3-4316-814a-7958b63f745c

 

Any help would be appreciated!

3 REPLIES 3
v-yutliu-msft
Community Support
Community Support

Hi @Daniel_Pipe ,

Since Android 5 is PowerApps' minimum required system, some functions may not perform well in this kind of device.

The recommended system is Android 7 or later with at least 4GB of RAM.

What's more, the device's memory size may affect the app's performance too.

I suggest you try a device with higher system and more memory size to see the app whether perform well.

Here's doc about system requirment for your reference:

https://docs.microsoft.com/en-us/powerapps/maker/canvas-apps/limits-and-config

 

 

Best regards,

Community Support Team _ Phoebe Liu

Community Support Team _ Phoebe Liu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Thanks for replying however that doesn't help. Of course we could buy a fleet of new devices but that costs money.
Android 5 is listed as supported yet no app loads at all. Even a nearly blank canvas with a single lable.
We don't need performance and PowerApps isn't consuming the RAM.
Supported should mean supported. I'm looking for a work around or response from MS.

Hi Daniel,

 

We are investigating the issue but have not been able to reproduce the issue thus far.  Could you please try updating the Android System WebView on your device and let us know?

 

Thank you!

Chris

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

secondImage

Demo Extravaganza is Back!

We are excited to announce that Demo Extravaganza for 2021 has started!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Top Solution Authors
Top Kudoed Authors
Users online (71,054)