cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

PowerApps changing URL of hyperlink

Hello Everyone,

 

I have a strange problem when someone puts a url to a site in a text input box, PowerApps seems to add extra characters to the url.

 

This is only happens if you have http or https, not if you just have www.

 

Has anyone ran into this before? I attached a picture of it happening (It adds &#58 and breaks the link)

 

Thanks

 

https-issue.JPG

10 REPLIES 10
Rebetcha
Level 10

Re: PowerApps changing URL of hyperlink

I have no experience with this issue. I also did some testing but could not reproduce it. I did some searching online. I found that &#58 is the HTML hypertext markup for a colon. On what kind of device is this app used? In the browser, on mobile, in the client etc.? Are there some formula's that do stuff with the input text?
Anonymous
Not applicable

Re: PowerApps changing URL of hyperlink

Hello Rebetcha,

 

There is no formatting in that column, it is just a multi line textbox.

 

This is being used in the browser. Chrome and Edge to be specific. 

 

I should also specify this happens when using PowerApps to customize a Sharepoint form.

Rebetcha
Level 10

Re: PowerApps changing URL of hyperlink

I have no success in reproducing. I made a multi line textbox, added a url from a side including https://, added a button with a lanch formula in the on select. Url is saved as it should and launches when I click the button. What is the formula in the text-property of the multi line textbox?
Anonymous
Not applicable

Re: PowerApps changing URL of hyperlink

Hello Rebetcha,

 

There is nor formula in the box, this only seems to happen if someone is copying and pasting the link in from a brower.

 

I do not know if this has something to do with it?

Rebetcha
Level 10

Re: PowerApps changing URL of hyperlink

I tested it that way and could not reproduce it. On what kind of device does this behavior occur? In the PowerApp apps on phone or tablet or is the app used in a browser or the Windows App?
Anonymous
Not applicable

Re: PowerApps changing URL of hyperlink

Hi Rebetcha,

 

I am using it in the web at the moment. I see it is saving it properly to our sharepoint list, the issue is when we pull it back up in PowerApps it is changing the colon into the HTML markup text.

 

The datafield is set to Parent.Default which it should be.

 

I tried several url's and they all do this.

 

Maybe its an issue with pulling the url back from sharepoint?

Rebetcha
Level 10

Re: PowerApps changing URL of hyperlink

How is the data saved and loaded from the list? By submitting a form and loading the SP-data directly in a gallery with data cards linked to the different columns? Or is the data loaded in a collation and is the saving done with the patch formula?
Anonymous
Not applicable

Re: PowerApps changing URL of hyperlink

It is by submitting the form and loading the data that way.

Rebetcha
Level 10

Re: PowerApps changing URL of hyperlink

Really strange. When I do this exactly the same way I cannot reproduce this behavior. I tried it several times, but in my case the url is loaded in the correct syntax. Could you share some screenshots of the screens where the issue occurs? With the properties and formulas?

Helpful resources

Announcements
New Ranks and Rank Icons in April

'New Ranks and Rank Icons in April

Read the announcement for more information!

Better Together’ Contest Finalists Announced!

'Better Together’ Contest Finalists Announced!

Congrats to the finalists of our ‘Better Together’-themed T-shirt design contest! Click for the top entries.

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

thirdimage

Community Summit North America

Innovate, Collaborate, Grow - The top training and networking event across the globe for Microsoft Business Applications

Top Solution Authors
Top Kudoed Authors
Users online (9,804)