cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
nikolec
Regular Visitor

PowerApps customized form not loading

Hi

 

My company uses PowerApps for our SharePoint site (for creating and editing list items). Everything was working just fine last Friday (September 13, 2019) and now (starting September 16, 2019) the customized PowerApps on all our New Experience SharePoint lists are not working. They're all stuck on the loading screen.

 

I observed that if the PowerApp is the default one (no fields removed or added), it loads just fine. I tried deleting one field (attachment field) from a default PowerApp and it was stuck on the loading screen.

 

We've tried using it on Chrome, Edge, and Firefox. I tried clearing my cache on Chrome and Edge, no progress.

It loads when using Internet Explorer but it still takes a while.

I have also tried turning off Delayed Load in the Settings.

 

This is not an isolated case, my entire team is experiencing the same problem.

19 REPLIES 19
Anonymous
Not applicable

Try type following code to "item" property at your form in powerapps:

 

If(
    IsBlank(SharePointIntegration.Selected) || IsEmpty(SharePointIntegration.Selected),
    First(your_sharepointlist_name),
    SharePointIntegration.Selected
    )

Hi @Anonymous, I did as you suggested but it's still stuck on the loading screen. Smiley Sad

Hardesh15
Super User
Super User

I am facing this same issue since morning..Don't know what is happened in background that my SharePoint custom is trying to load ….it keeps loading.

 

Any help?

Hi @Hardesh15,

 

It’s been more than half a year so I’m hoping my memory hasn’t failed me yet...

Everything went back to normal in around 4 days; apparently it had something to do with the PowerApps CDN, according to the PowerApps Staff I got to talk to. Can’t really do much about it, unfortunately.

 

Hoping it works soon, cheers.

Same issue here since this morning - any news on this?

it works in IE11

Regards

Dieter

@DieterLamb1

For me when i published it then 4 to 5 clicks on new tab worked well in any browser(Chrome, edge and Mozila). After that it goes to loading n loading......

Designer and infopath days were more charming than this.

I have logged a ticket with Microsoft. Lets hope for best. 

Anonymous
Not applicable

@DieterLamb1 

The same problem since morning.

I hope it is on the Microsoft side. Once I re-publish Form it works for 1-2 tries and than again loading and loading.

Cache Cleaning does not work, Ctrl + F5 as well...

 

I am frustrated....

This is happening for us as well... 

In the list, when you access already submitted items.. the form launches in a blank mode or with the spinning wheel......
Is there any way we can open up a ticket with Microsoft about this?

Thank you

Anonymous
Not applicable

Our SharePoint custom forms has now been down several hours. ☹️ We had issues this weekend too, and the week before that when the onSave event stopped working. Seems to me Microsoft Power platform isn't very stable...

Helpful resources

Announcements
Microsoft 365 Conference – December 6-8, 2022

Microsoft 365 Conference – December 6-8, 2022

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

Difinity Conference 2022

Difinity Conference 2022

Register today for two amazing days of learning, featuring intensive learning sessions across multiple tracks, led by engaging and dynamic experts.

European SharePoint Conference

European SharePoint Conference

The European SharePoint Conference returns live and in-person November 28-December 1 with 4 Microsoft Keynotes, 9 Tutorials, and 120 Sessions.

Power Apps Ideas

Changes to Ideas Coming

We are excited to announce a new way to share your ideas for Power Apps!

Top Solution Authors
Top Kudoed Authors
Users online (1,926)