cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Anonymous
Not applicable

PowerApps multiple lines or hyperlink SharePoint column not updating PowerApps Form

I have a SharePoint list with hyperlink column. In PowerApps form, the hyperlink column is single line by default. When user enters in hyperlink value, and clicks Save, the SharePoint list is updated correctly but not the PowerApps form. When the user clicks Edit to edit the list item, the hyperlink value is blank and not reflecting the changes made in the form. However, only when the user refreshes the page, and clicks Edit, the hyperlink column in the form reflects the updated value.

 

I've tried to substitute the hyperlink column with a single line of text column, and this works. However, the user hyperlinks are normally very long, so I change it to multiline, and have the same problem with it not updating the form unless the page is refreshed. 

 

Anyone else having this issue with hyperlink or multline column?

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Dual Super User III
Dual Super User III

Re: PowerApps multiple lines or hyperlink SharePoint column not updating PowerApps Form

Hi @Anonymous 

 

The issue you are seeing might be because the sharepoint list data source is not getting refreshed on the save button. Please add the Refresh(<<SPList>>) after submit form query.
 
I tried it myself and I am able to get the get the newly created record in my powerapp.MicrosoftTeams-image (59).png

 

Hope this Helps!

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

View solution in original post

2 REPLIES 2
Dual Super User III
Dual Super User III

Re: PowerApps multiple lines or hyperlink SharePoint column not updating PowerApps Form

Hi @Anonymous 

 

The issue you are seeing might be because the sharepoint list data source is not getting refreshed on the save button. Please add the Refresh(<<SPList>>) after submit form query.
 
I tried it myself and I am able to get the get the newly created record in my powerapp.MicrosoftTeams-image (59).png

 

Hope this Helps!

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

View solution in original post

Highlighted
Anonymous
Not applicable

Re: PowerApps multiple lines or hyperlink SharePoint column not updating PowerApps Form

Thank you @yashag2255!!!! I put the Refresh(datasource) on the OnSuccess Property of my edit form and it worked!

Helpful resources

Announcements
secondImage

New Return to Workplace

Reopen responsibly, monitor intelligently, and protect continuously with solutions for a safer work environment.

August 2020 CYST Challenge

Check out the winners of the recent 'Can You Solve These?' community challenge!

Experience what’s next for Power Apps

Join us for an in-depth look at the new Power Apps features and capabilities at the free Microsoft Business Applications Launch Event.

Check this Out

Helpful information

Featuring samples like Return to the Workplace and Emergency Response Applications

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Users online (5,071)