cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
LucianB
Advocate II
Advocate II

PowerApps not loading on iPad

Hi,

Just installed PowerApps on couple of iPads - all of them seems to have same issue - Powerapps is not loading, freezing at start-up screen (purple one). I wait nearly 10 minutes, nothing happened.

I did installed latest version of iOS available, as well latest version of Powerapps.

I think this is a  serious issue and I really need help!

Thank you very much.

27 REPLIES 27

To move past the purple splash screen, the app needs to connect to

https://create.powerapps.com

https://powerappsclient.blob.core.windows.net

https://web.powerapps.com

https://paplayercdn.azureedge.net

https://vortex.data.microsoft.com

 

I'm also seeing a request to an apple.com subdomain:

https://*.apple.com

 

If these don't work, would it be possible for you to detect failed network requests from your iPad using a tool like Fiddler (if you have a PC), Wireshark (if you have a Mac), or Charles (on the iPad)?

Have we come up with a solution for this yet? I have about 20+ ios device that I would like to deploy a powerapp to but I need to maintain the integrity of our network security.

Chris
Power Apps
Power Apps
JacobSVVJC
Frequent Visitor

unfortunately no. I have added all the websites listed and the IP addresses to the allowed websites in the restrictions section in ios but it is still not allowing me to pass the purple screen.

Hi Jacob,

Useless, don't waste your time. I had to move out from Microsoft just because PowerApps can't replace Access Web App in anyway. Contact me if you need a proper alternative.

Anonymous
Not applicable

Im facing the same issue here. I have iPad set up with web content filter. I have entered as best i can the endpoints from here:

https://docs.microsoft.com/en-us/office365/enterprise/urls-and-ip-address-ranges

 

But the app hangs during loading. Worth noting that it authenticates the user fine though.

 

Did you ever find a solution?

 

The app works fine once i remove the web content filter. I have tried many routes including using Fiddler to try to capture what might be blocked, but im going around in circles.

 

Thanks in advance.

Try adding loopbacks into your whitelist:

 

localhost

https://localhost

http://localhost:*

http://127.0.0.1:*

 

 

 

 

ChadEvans
Regular Visitor

Was a fix ever found for this?

Helpful resources

Announcements
PA_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

Power Query PA Forum 768x460.png

Check it out!

Did you know that you can visit the Power Query Forum in Power BI and now Power Apps

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

PowerPlatform 768x460.png

Microsoft Learn

Check out our new Discover Your Career Path blog post series and get all the details.

Users online (1,209)