cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
hsoetikno
Level: Powered On

PowerApps not saving, properties not loading

I was working on my PowerApps form yesterday and this morning, until it decided to stop working. I was working on Google Chrome on my Mac.

 

The problem occurred after I made a few changes on my SharePoint list data source. A couple of topics suggested removal and re-add of data source. However, the below message appears when I try to do so.

 

My session ID is 9636f9e8-6b31-475e-b318-af4856c01790.

 

image.png

 

 

Problem 1: When I select a control, their properties are not loading on both the Properties and Advanced windows (on the right), and the formula bar (at the top).

 

Screen Shot 2019-11-27 at 1.14.59 pm.png

 

Problem 2: When I try saving PowerApps, the screen will say "Saving..." but will not progress from there. I waited for about 30 minutes on Google Chrome, and then tried to do the same action from Microsoft Edge with no luck.

 

I have read a couple of forum topics here suggesting trying to save via Microsoft Edge before returning to Google Chrome. The same problems above existed when I opened the app on Microsoft Edge.

 

Any help would be much appreciated.

 

4 REPLIES 4
Community Support Team
Community Support Team

Re: PowerApps not saving, properties not loading

HI @hsoetikno ,

Based on the issue that you mentioned, I have made a test on my side, and don't have the issue that you mentioned.

 

The user @jflores00 has faced same issue with you, please check the response within the following thread:

https://powerusers.microsoft.com/t5/Building-Power-Apps-Formerly/Formula-field-is-disabled-and-data-...

 

On your side, please consider re-store your app to previous version, then check if the issue is solved.

Restore app to previous version

 

In addition, please also consider edit your app using previous version of PowerApps Studio as below:

https://create.powerapps.com/v3.19104.33.130671691/studio/# 

then check if the issue is fixed. Then made some changes to your app, re-publish it again.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
hsoetikno
Level: Powered On

Re: PowerApps not saving, properties not loading

Thanks for your response @v-xida-msft 

 

I've tried restoring previous version. The previous version that works starts from 3 versions away, which would require quite a significant effort to restore the code gap to current version, especially that I can't see the codes on the current version as selecting these properties on the current version shows a blank field (e.g. OnSelect properties).

 

Do you have any suggestion on how I can access the code from previous version if I have to continue with this process?

 

Also, any idea on what could have triggered this bug? So I can avoid re-introducing the bug as I go through my code update. The only thing that comes to mind before the bug comes, was that I was updating my data source (SharePoint list) and the PowerApps. I'm not sure why this would have affected 3 versions though.

Community Support Team
Community Support Team

Re: PowerApps not saving, properties not loading

Hi @hsoetikno ,

Have you taken a try to refresh the SP List data source manually within your app after you made some changes to your SP List?

 

Currently, I could not reproduce your issue on my side. Please consider capture the Session ID of your app, then submit an assisted support ticket along with the captured Session ID through the following link:

https://powerapps.microsoft.com/en-us/support/pro

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
hsoetikno
Level: Powered On

Re: PowerApps not saving, properties not loading

@v-xida-msft 

I sure have, and it will stay on "Refreshing" and not progress. I had this open for 2 hours without any luck.

 

What I've also found is that, while trying to incorporate most recent code into the restored version, if I copy all my old code that contains references to old SharePoint list structure, the app runs into the same exact problem. But if I copy line by line and manually rewrites the lines to reflect updated SharePoint list structure, the app won't crash.

Helpful resources

Announcements
New Ranks and Rank Icons in April

'New Ranks and Rank Icons in April

Read the announcement for more information!

Better Together’ Contest Finalists Announced!

'Better Together’ Contest Finalists Announced!

Congrats to the finalists of our ‘Better Together’-themed T-shirt design contest! Click for the top entries.

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

thirdimage

Community Summit North America

Innovate, Collaborate, Grow - The top training and networking event across the globe for Microsoft Business Applications

Top Solution Authors
Top Kudoed Authors
Users online (7,480)