cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
forcedLightning
Advocate I
Advocate I

PowerApps sign in loop on Android

Hello! I am running into an issue where users with Android phones are unable to log into PowerApps with Chrome. It asks them over and over to authenticate, but never actually does. I believe this issue has been brought up previously, but with no resolution.  I'm going to submit a ticket to Microsoft as well, as this NEEDS to be fixed as soon as possible. I can't seem to find a rhyme or reason to the glitch; some android phones are able to log in, and others can't. I've tried clearing cache, cookies, removing the account from both Chrome and the phone, etc. I thought it was an issue on older phones only, but now I just saw it on a Pixel 4. This has been an issue since 2017. Can someone please help?

 

Error text: 

Unable to obtain access token for resource 'https://service.powerapps.com/'. Error from ADAL.js: login_required (AADSTS50058: A silent sign-in request was sent but no user is signed in. The cookies used to represent the user's session were not sent in the request to Azure AD. This can happen if the user is using Internet Explorer or Edge, and the web app sending the silent sign-in request is in different IE security zone than the Azure AD endpoint (login.microsoftonline.com).
Trace ID: 75083d4e-0fb8-4008-a65c-3ea30d6e6b00
Correlation ID: 57d44100-85ea-4e30-8c4e-7c8892aca657
 
"Solution" article that offers no solution to users, or even power users: https://support.microsoft.com/en-us/help/3203929/using-adal-to-authenticate-from-android-devices-fai...
 
 
errordetails.jpg
3 REPLIES 3
WarrenBelz
Super User
Super User

HI @forcedLightning ,

I am wondering why you are using Chrome rather than the app. I have a couple of hundred users in the field using both Android and iPhones/iPads and have never had any authentication issues apart from 1 related to iOS devices trying to run deep-linked apps in Safari (now fixed).

This may not be relevant, but I have had issues viewing photos in SharePoint Libraries on mobile devices using the {link} property and was told it had something to do with "anonymous access" used by PowerApps on URLs.

 

Fair point, WarrenBelz, and I appreciate your thoughts. Our organization is simply not ready to require users to download an app to their personal devices in order to access organizational tools and information. Besides that, how can PowerApps have ignored 1/4 of all of their mobile users and not fixed the issue? (if we assume 50/50 with iOS/Android, and 50/50 app/browser)

Hi @forcedLightning ,

I must admit I never thought of that one. The app is free and does not impose a lot of space on the device and many of our users use their private devices.

The issues I mentioned with Safari also included PowerApps not really working the way it should (although it did launch from PowerApps with proper authentication). I suspect that the creators of the architecture of a device browser did not plan on the type of processing load running something like PowerApps inside would impose, nor did the creators of PowerApps plan to run it in this environment (which is why they provided a free app).

The other thing, and I am guessing here, is that the authentication issues may revolve around (as you have stated), this lack of foresight into what users may want to do.

Helpful resources

Announcements
PA_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Welcome Super Users.jpg

Super User Season 2

Congratulations, the new Super User Season 2 for 2021 has started!

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Top Solution Authors
Top Kudoed Authors
Users online (1,002)