cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
cpan
Level: Powered On

PowerApps slow performance after disable TLS 1.0 registry key on On-premises data gateway server

We are disabling the TLS 1.0 on the On-premises data gateway server. Once we disable the TLS 1.0 registry on Windows server, the PowerApps performance becomes extremely slow.  Below is the setup:

 

On-Premises data gateway server

Windows 2016

On-Premises data gateway version: 3000.21.22 (December 2019 (Release 2))

Registry Keys:

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\v4.0.30319]"SchUseStrongCrypto"=dword:00000001 [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\.NETFramework\v4.0.30319]"SchUseStrongCrypto"=dword:00000001

 

As soon as we disable the TLS 1.0 in registry, it slows down the PowerApps performance. Below is the registry to disable TLS 1.0

            reg add "HKLM\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.0\Client" /v Enabled /t REG_DWORD /d 0 /f

            reg add "HKLM\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.0\Client" /v DisabledByDefault /t REG_DWORD /d 0 /f

            reg add "HKLM\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.0\Server" /v Enabled /t REG_DWORD /d 0 /f

            reg add "HKLM\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.0\Server" /v DisabledByDefault /t REG_DWORD /d 0 /f

 

Is there additional setup needs to be done on the gateway server?

1 ACCEPTED SOLUTION

Accepted Solutions
cpan
Level: Powered On

Re: PowerApps slow performance after disable TLS 1.0 registry key on On-premises data gateway server

We are able to solve the issue by installed the latest "Microsoft SQL Management Studio" along with the "On-premises data gateway" service. It appears a driver from Management Studio is needed to solve the slow PowerApps performance issue after disabled the TLS 1.0/1.1.

View solution in original post

2 REPLIES 2
Microsoft v-siky-msft
Microsoft

Re: PowerApps slow performance after disable TLS 1.0 registry key on On-premises data gateway server

@cpan 

I suggest you submit a support ticket to Microsoft for further assistance.

https://admin.powerplatform.microsoft.com/support 

Sik

cpan
Level: Powered On

Re: PowerApps slow performance after disable TLS 1.0 registry key on On-premises data gateway server

We are able to solve the issue by installed the latest "Microsoft SQL Management Studio" along with the "On-premises data gateway" service. It appears a driver from Management Studio is needed to solve the slow PowerApps performance issue after disabled the TLS 1.0/1.1.

View solution in original post

Helpful resources

Announcements
New Ranks and Rank Icons in April

'New Ranks and Rank Icons in April

Read the announcement for more information!

Better Together’ Contest Finalists Announced!

'Better Together’ Contest Finalists Announced!

Congrats to the finalists of our ‘Better Together’-themed T-shirt design contest! Click for the top entries.

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

thirdimage

Community Summit North America

Innovate, Collaborate, Grow - The top training and networking event across the globe for Microsoft Business Applications

Top Solution Authors
Top Kudoed Authors
Users online (4,486)