cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted

PowerApps web player not loading apps

Hi

 

I have an app that I just moved to a new tenant and finished rewiring up connections to SharePoint. The web player (Chrome/Edge) will not play the app. It sits at the animated 4 dots and never loads.

 

The app downloads and works fine when using PowerApps on a device or in studio.

 

Also, web studio runs the app fine...

 

How to go about troubleshooting something like this?

 

Paul

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Power Apps
Power Apps

Re: PowerApps web player not loading apps

No. that explains it then. LoadData() is not supported in WebPlayer and there is a known issue that we are trying to address where if you use LoadData in 'OnStart' it hangs in the webPlayer. Workaround would be to not use it until we fix the issue.

View solution in original post

9 REPLIES 9
Highlighted
Community Support
Community Support

Re: PowerApps web player not loading apps

Hi @paulculmsee,

 

I am a little confused here.

"The web player (Chrome/Edge) will not play the app. It sits at the animated 4 dots and never loads."

"Also, web studio runs the app fine.."

 

Could you please share more details when you are trying to play this app under Chromeor Edge?

When app never loads, do you mean to open the App through the Dynamics 365 App portal?

Is it running under the following URL prefix?

https://web.powerapps.com/webplayer

Besides, when saying it works, do you mean it works under:

https://as.create.powerapps.com/studio

 

 

Please take a try to open the App under InPrivate mode of the Browser (also take a try to clear the Browser cache), see if that would help.

Regards,

Michael

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted

Re: PowerApps web player not loading apps

Sorry I was unclear...

 

The app refuses to load when I go to https://web.powerapps.com/webplayer, but will load in studio. I actually run it in inPrivate mode all the time because I have multiple client tenants. 

 

The reference to Chrome/Edge was related to why I think it may not be cache-related. 

 

Just tried again just now using Chrome... nogo

Highlighted

Re: PowerApps web player not loading apps

Cool (well in a nerdy way).

 

Hey @v-micsh-msft, I have confirmed that this app will not work on the webplayer on 2 different tenants. 

 

The app has 3 data connections to SharePoint, 1 to flow and 2 to custom API's.

 

It looks to me like this is reproducable on other tenants, so it might be a bug with PowerApps player?

 

Paul

Highlighted
Power Apps
Power Apps

Re: PowerApps web player not loading apps

Hi,

Sorry that you are experiencing this issue. Could you please provide the sessionId when you play the app in webPlayer so that we can investigate further?

Here's how to get sessionID in the web Player:

1. Open it in chrome.:

2. hit F12

3. select "Console" tab

4. enter this command: "Core.Telemetry.Log.sessionId"

 

You will get a GUID similar to this: "b986f829-ef2f-9c29-21c5-e68538a908d4"

If you can provide us the sessionID we can investigate this issue further on our end.

Highlighted
Power Apps
Power Apps

Re: PowerApps web player not loading apps

Hey Paul, we have recently discovered an issue with using LoadData function in WebPlayer. It causes the app to hang if it is used in OnStart rule. Could you check if your app uses LoadData? And as Hemanth mentioned, session id would help a lot.

 

Highlighted

Re: PowerApps web player not loading apps

Yeah I do use LoadData during onStart... still need that session id? 🙂

Highlighted
Power Apps
Power Apps

Re: PowerApps web player not loading apps

No. that explains it then. LoadData() is not supported in WebPlayer and there is a known issue that we are trying to address where if you use LoadData in 'OnStart' it hangs in the webPlayer. Workaround would be to not use it until we fix the issue.

View solution in original post

Highlighted

Re: PowerApps web player not loading apps

That raises an idea... If the type of player used to run the app and the platform was available in the same way that location data is available, I could work around the app to be "online only" when run from a web player...

Highlighted
Power Apps
Power Apps

Re: PowerApps web player not loading apps

Hi,

Yes we are aware of this limitation and are looking into how to add that capability in the product. I agree, with the ability to detect the platform, you can easily build a workaround for these kinds of cases.

 

Thanks,

 

Helpful resources

Announcements
secondImage

Demo-Extravaganza 2020

Check out these cool Power Apps & vote on your favorite!

secondImage

Robotic Process Automation

Let's talk about the solution provided by Microsoft for Robotic Process Automation (RPA)

secondImage

Community Highlights

Check out whats happening in Power Apps

secondImage

Community User Group Member Badges

FIll out a quick form to claim your community user group member badge today!

Top Solution Authors
Top Kudoed Authors
Users online (7,246)