cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Kudo Kingpin
Kudo Kingpin

PowerAppsNotification Notifications stopped working

I have two apps, a dispatch app and a staff app.

 

  • The dispatch app users (around 12) have PowerApps Plan 2 and the app has the PowerAppsNotification connector.
  • The staff app users (around 100) have Powerapps for Office 365 plan.

Up until today, the dispatch app users could send a notification to the iPhone of a staff app user and they would get the notification which was consistent with the information supplied here. Now, the notification are not being delivered to any of the staff app users. If a PowerApps Plan 2 user logs into the staff app however they can receive a notification.

 

I got funding for this project based on the this information as well as testing that confirm that this would work.

I have thoroughly tested this with a bunch of iPhones lined up with various users logged in and can confirm this behavior.

 

Did something change or was this information incorrect to begin with? In either case I have a real problem on my hands.

1 ACCEPTED SOLUTION

Accepted Solutions
Kudo Kingpin
Kudo Kingpin

False alarm!

After my original app was corrupted for reasons still unclear (see this thread for details), I copied everything over to a new "shell" of an app (which fixed that issue immediately). What I forgot to do though was update the notification connector with the new target ID for the app (which is now different because I copied both over to new apps and got rid of the old ones. 

 

So the fix was to go to connectors > edit > Target application (The URL or ID shown under app details tab)  and update with 1934003d-35b9-46ae-a9f4-e5d121630dc4 (ID of new app that receives the notifications).

View solution in original post

1 REPLY 1
Kudo Kingpin
Kudo Kingpin

False alarm!

After my original app was corrupted for reasons still unclear (see this thread for details), I copied everything over to a new "shell" of an app (which fixed that issue immediately). What I forgot to do though was update the notification connector with the new target ID for the app (which is now different because I copied both over to new apps and got rid of the old ones. 

 

So the fix was to go to connectors > edit > Target application (The URL or ID shown under app details tab)  and update with 1934003d-35b9-46ae-a9f4-e5d121630dc4 (ID of new app that receives the notifications).

View solution in original post

Helpful resources

Announcements
New Badges

New Solution Badges!

Check out our new profile badges recognizing authored solutions!

New Power Super Users

Congratulations!

We are excited to announce the Power Apps Super Users!

Power Apps Community Call

Power Apps Community Call: February

Did you miss the call? Check out the Power Apps Community Call here.

Microsoft Ignite

Microsoft Ignite

Join digitally, March 2–4, 2021 to explore new tech that's ready to implement. Experience the keynote in mixed reality through AltspaceVR!

Top Solution Authors
Top Kudoed Authors
Users online (79,576)