cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
BenGCG
New Member

PowerBI Tile missing X axis labels

When I use a powerBI tile I can see the x-axis in the design mode, but when I publish to SharePoint it is not rendering the aspect ratio correctly and cutting off the bottom and right side of the tile.  Any idea how to fix? 

 

BenGCG_0-1620545150103.png

Better pics...

BenGCG_0-1620545248377.png

Sharepoint version

BenGCG_1-1620545269367.png

 

 

 

4 REPLIES 4
v-xiaochen-msft
Community Support
Community Support

Hi @BenGCG ,

 

What is the screen size setting of your powerapps?

If you want to display the entire screen without black borders, there are two ways.

1\ 

v-xiaochen-msft_0-1620614826748.png

2\ 

v-xiaochen-msft_1-1620614903191.png

v-xiaochen-msft_2-1620614965614.png

v-xiaochen-msft_3-1620615055853.png

<iframe width="1024px" height="768px" src="https://web.powerapps.com/webplayer/iframeapp?source=iframe&screenColor=rgba(104,101,171,1)&appId=/providers/Microsoft.PowerApps/apps/[AppID]" />

// In my example, the size of my app is 640x1136, so I will use this formula:

<iframe width="640px" height="1136px" src="https://web.powerapps.com/webplayer/iframeapp?source=iframe&screenColor=rgba(104,101,171,1)&appId=/providers/Microsoft.PowerApps/apps/my app id" />

 

It should be noted that before using iframe, please modify the settings as shown below.

v-xiaochen-msft_4-1620615309159.png

 

The difference between the two methods is their resolution.

But none of them have a black border.

 

Best Regards,
Wearsky
If my post helps, then please consider Accept it as the solution to help others. Thanks.

 

 

 

BenGCG
New Member

@v-xiaochen-msft 

 

Thank you!! I tried this and I still do not see the powerBI tile rendering correctly. 

 

It does render correctly if run the webapp URL.  Here are some screenshots of what I tried. 

 

BenGCG_0-1620675556965.png

The underlined weblink works fine, I might just have users use that instead of trying to host it in a page? Is there any downside to that? 

v-xiaochen-msft
Community Support
Community Support

Hi @BenGCG ,

 

Please check if your settings are the same as the image below:

v-xiaochen-msft_0-1620695856916.png

After changing the settings, please save the app and publish the app.

 

In addition, in order to protect your privacy, the staff has deleted your images.

 

Best Regards,
Wearsky
If my post helps, then please consider Accept it as the solution to help others. Thanks.

 

BenGCG
New Member

Hi @v-xiaochen-msft 

 

Even when I check all those settings it doesn't draw the BI tile fully when in Sharepoint. Is there something on the BI side I need to adjust or set the tile size too? Honestly I just switched to not imbedding the app at all and running it from the "Play" link instead for users. 

Helpful resources

Announcements
Ignite 2022

WHAT’S NEXT AT MICROSOFT IGNITE 2022

Explore the latest innovations, learn from product experts and partners, level up your skillset, and create connections from around the world.

Power Apps Africa Challenge 2022

Power Apps Africa Challenge

Your chance to join an engaging competition of Power Platform enthusiasts.

Super User 2 - 2022 Congratulations

Welcome Super Users

The Super User program for 2022 - Season 2 has kicked off!

September Events 2022

Check out all of these events

Attend in person or online, there are incredible conferences and events happening all throughout the month of September.

Users online (1,891)