cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
irondinges
Advocate II
Advocate II

PowerBI tile - dashboard tiles not showing in list

I am building an app with an embedded BI tile, using the "Power BI tile" object.

 

After selecting the workspace (My Workspace), the dashboard (a newly created dashboard), the "Tile" field remains grayed out.

I have pinned two tiles to this dashboard.

 

I am able to insert tiles from other BI dashboards that were created some time ago.

 

Why am I not able to see these tiles?

 

Based on this thread: https://powerusers.microsoft.com/t5/Building-Power-Apps/Power-BI-dashboard-elements-not-showing-up-a...

I tried to specify new names for the dashboard tiles, but they still aren't appearing.

 

I have closed and re-opened the app several times, however the tiles still aren't showing.

 

In terms of security, there is no issue, the apps, reports and dashboards are all mine and created with my account, I have full access.

1 ACCEPTED SOLUTION

Accepted Solutions
irondinges
Advocate II
Advocate II

I've once again hit this issue, and the "fix" mentioned earlier did not work.

 

It seems to me that there is something at play here, I'm wondering if there is perhaps some internal polling service that refreshes the tile list?

 

EDIT: After bashing my head against the wall a bit more, I remembered the other tip from one of the other threads: you need to rename the tile after publishing it to the dashboard. Even if it already has a name, it seems PowerApps can only pick it up if it has been renamed.

View solution in original post

3 REPLIES 3
irondinges
Advocate II
Advocate II

I searched a bit further and found the solution on this post:

https://powerusers.microsoft.com/t5/Building-Power-Apps/Power-BI-Tiles-unable-to-find-tiles-in-dashb...

 

Specifically, I signed out from PowerApps, closed the PowerApps tab I was working on, signed in again (without restarting browser), and the tiles were showing.

irondinges
Advocate II
Advocate II

I've once again hit this issue, and the "fix" mentioned earlier did not work.

 

It seems to me that there is something at play here, I'm wondering if there is perhaps some internal polling service that refreshes the tile list?

 

EDIT: After bashing my head against the wall a bit more, I remembered the other tip from one of the other threads: you need to rename the tile after publishing it to the dashboard. Even if it already has a name, it seems PowerApps can only pick it up if it has been renamed.

View solution in original post

thx! This did the job for me. (only after 2h+ of searching every where )

Helpful resources

Announcements
PA_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

Power Query PA Forum 768x460.png

Check it out!

Did you know that you can visit the Power Query Forum in Power BI and now Power Apps

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

R2 (Green) 768 x 460px.png

Microsoft Dynamics 365 & Power Platform User Professionals

DynamicsCon is a FREE, 4 half-day virtual learning experience for 11,000+ Microsoft Business Application users and professionals.

Users online (1,637)