cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
MattP13
Resolver I
Resolver I

PowerBIIntegration connection not working?

Has anyone else been experiencing issues with creating a connection with PowerBIIntegration form the Powerapps visual in Power-BI?

I've been trying all day to create a connection and keep running into the same 2 problems:

 

1. Clicking the Powerapps studio button from the visual in PowerBI takes me to the Powerapps homepage instead of the actual powerapp in powerapps studio.

2. Sometimes I will receive a popup saying "Sorry there was an error with Powerapps studio"

 

I've tried creating a connection with both existing and new apps in different environments but keep hitting this roadblock.

 

Here are the details provided with the error message:

 

Failed to create or join session (API: JoinSession)xhr error. Status: 401, response: Invalid join token

 

 

2 ACCEPTED SOLUTIONS

Accepted Solutions
RezaDorrani
Dual Super User II
Dual Super User II

Hi @MattP13 

 

I did a step by step walkthrough video some time back on Power Apps visuals in Power BI.

Hope this helps.

https://www.youtube.com/watch?v=NTUfX9HNdK0

 

Note: Power Apps visuals in Power BI are not supported for Gov tenants.

 

--------------------------------------------------------------------------------
If this post helps answer your question, please click on “Accept as Solution” to help other members find it more quickly. If you thought this post was helpful, please give it a Thumbs Up.

Thanks,
Reza Dorrani, MVP
YouTube
Twitter

View solution in original post

Update:

 

I just got it working. I took all the same steps but from the Power-BI service. Before I was attempting on the Power-BI Desktop.

🙃.

 

View solution in original post

10 REPLIES 10
RezaDorrani
Dual Super User II
Dual Super User II

Hi @MattP13 

 

I did a step by step walkthrough video some time back on Power Apps visuals in Power BI.

Hope this helps.

https://www.youtube.com/watch?v=NTUfX9HNdK0

 

Note: Power Apps visuals in Power BI are not supported for Gov tenants.

 

--------------------------------------------------------------------------------
If this post helps answer your question, please click on “Accept as Solution” to help other members find it more quickly. If you thought this post was helpful, please give it a Thumbs Up.

Thanks,
Reza Dorrani, MVP
YouTube
Twitter

View solution in original post

Hi @RezaDorrani ,

 

Thanks for the response. I thoroughly enjoy all the content you push out to help all of us in the community, you are a true asset!

I did watch this video and make sure that both my database environment version was up to date and that my TDS Endpoints setting was enabled in my environment but I am still running into the same issues 😞

 

Though the CDS data is imported via Dynamics Odata API within my Power-BI Report.

Would that be the reason I'm having this issue? 

Does the PowerApps visual in Power-BI only work by initiating via the "Analyze in Power BI" button within the entities section in PowerApps?

Update:

 

I just got it working. I took all the same steps but from the Power-BI service. Before I was attempting on the Power-BI Desktop.

🙃.

 

View solution in original post

Reza Do you have a video using a previous created app , instead of creating one on the fly ?

Dave

Hi @DAVIDPOWELL ,

 

When you add the Power Apps visual and pass some data points to it, you will get the option to add an app or choose an app.

 

--------------------------------------------------------------------------------
If this post helps answer your question, please click on “Accept as Solution” to help other members find it more quickly. If you thought this post was helpful, please give it a Thumbs Up.

Thanks,
Reza Dorrani, MVP
YouTube
Twitter

Correct and when I go into to choose the app I want(instead of creating one). No fields are coming up for me when I use the Powerbintegration object. ?  just one field called "Customer".  which I did not even choose.

in powerapps.  I have a question posted on this issue.  Thanks for the reply here.

 

Hi @DAVIDPOWELL ,

 

Did you try passing more data points to the Power Apps visual?

Then edit app directly from visual itself and publish app.

Caching issues are well known.

DAVIDPOWELL
Post Prodigy
Post Prodigy

Reza, Yes,  followed the instructions to the rule.

 

DAVIDPOWELL
Post Prodigy
Post Prodigy

PowerBiIntegration_error.png

 

just an screenshot of the app showing no fields for powerbiintegration object ?

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Top Kudoed Authors
Users online (1,222)