cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
New Member

Powerapp office365 datasource not working

Hi, I'm trying to connect to an office365 datasource but it desnt seem to be seleactable once i have added it. I go through the short wizard, authenticate and then it gets added as a datasource - i can even update the authentication and that all works fine. However when i try and associate this datasource with an object (gallery for example) i click on the link i get a list of datasources - but my office365 one isn;t there - i click into a wizard from there to add one - this gets added as o365users_2 - but again this is not selectable from the initial screen so i cant use it to build an app from. Any idea why this wouldnt be available? Thanks, Richard

 

Now maanged to add pic - so in the screen below i can;t click on either of the office365 datasources - though they seem to be valid....

 

Capture.PNG

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Super User
Super User

Re: Powerapp office365 datasource not working

The Office365Users data source doesn't return a table, so it can't be used as the data source of the Gallery. There are calls in the data source that will return a table of records and you can use that in the Items property of the Gallery.

 

Try this to get started. Go to the Items property of your Gallery and in the formula bar add:

Office365Users.SearchUser()


--------------------------------------------------------------------------------
If this post helps answer your question, please click on “Accept as Solution” to help other members find it more quickly. If you thought this post was helpful, please give it a Thumbs Up.

View solution in original post

4 REPLIES 4
Highlighted
Super User
Super User

Re: Powerapp office365 datasource not working

The Office365Users data source doesn't return a table, so it can't be used as the data source of the Gallery. There are calls in the data source that will return a table of records and you can use that in the Items property of the Gallery.

 

Try this to get started. Go to the Items property of your Gallery and in the formula bar add:

Office365Users.SearchUser()


--------------------------------------------------------------------------------
If this post helps answer your question, please click on “Accept as Solution” to help other members find it more quickly. If you thought this post was helpful, please give it a Thumbs Up.

View solution in original post

Highlighted
Power Apps
Power Apps

Re: Powerapp office365 datasource not working

For further help with how to use the Office 365 connector, check out the documentation we have for it here: https://docs.microsoft.com/en-us/powerapps/connections/connection-office365-users

 

The documentation lists out all of the valid functions you can use on the connector to help you get started.

Highlighted
New Member

Re: Powerapp office365 datasource not working

Thanks Jeff - that got it. Got slightly confused that the items property does not appear on the right in the properties section but in a drop down near the top left 🙂

 

ANyway it's working now and managed to get data back - thanks for the reply

Highlighted
New Member

Re: Powerapp office365 datasource not working

Thanks for the pointer

Helpful resources

Announcements
secondImage

Demo-Extravaganza 2020

Check out these cool Power Apps & vote on your favorite!

secondImage

Community Highlights

Check out whats happening in Power Apps

secondImage

Community User Group Member Badges

FIll out a quick form to claim your community user group member badge today!

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors
Users online (11,306)