cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
UserInterface7
Level: Powered On

Powerapp stopped displaying results.

Hi all. I have a powerapp that when I click a button adds all my rooms to check in the morning, then the powerapp shows me filtered results that are created for that day. 

 

The other day this stopped working, I was walking to work and running the button (as it takes a while to run) and as it was adding the rooms (line items) I lost mobile reception and I ended up with a few rooms, however, most were missing.

I then hit the button again (to create them again) but no new ones showed up. I then hit it again for good measure but again no new ones showed up.

When I got to work I looked on SharePoint instead and could see the original few rooms it created before losing reception plus the 2 full sets from me hitting the button twice.

 

I assumed that the problem would just go away the next day but now every day when I run it I get the objects show in SharePoint but not in the powerapp.

 

Does anyone know what would have happened by losing reception, and what a possible fix might be?

 

Button:

Collect('Checklist',{Title: "4.25"},{Title: "8.12"},{Title: "8.15"},{Title: "11.13"},{Title: "12.22"},{Title: "13.04"},{Title: "13.08"},{Title: "13.19"},{Title: "15.01"},{Title: "15.05"},{Title: "15.06"},{Title: "15.16"},{Title: "15.18"},{Title: "6.13"},{Title: "8.14"})

Gallary:

SortByColumns(Filter('Checklist', IsToday(Created)), "Title", If(SortDescending1, Descending, Ascending)) 

 

6 REPLIES 6
Community Support Team
Community Support Team

Re: Powerapp stopped displaying results.

Hi @UserInterface7,

 

Could you please share a screenshot of your PowerApps app's configuration?

Could you please show more details about your SharePoint list?

Further, could you please show a bit more about the Checklist within the formula of the Items property of Gallery control that you mentioned? Is it a SharePoint list data source?

 

I suppose that the Checklist that you mentioned wihtin the Items property of Gallery control is a SharePoint list data source, is it true? I have made a test on my side and don't have the issue that you mentioned. My PowerApps app's configuration as below:8.JPG

 

The Items property of the Gallery control set to following formula:

SortByColumns(Filter('20180402_case1',IsToday(Created)), "Title", If(SortDescending1, Descending, Ascending))

or 

SortByColumns(Filter('20180402_case1',IsToday(Created)=true), "Title", If(SortDescending1, Descending, Ascending))

The OnSelect property of Button control set to following formula:

Collect('20180402_case1',{Title:"14.01"})

Note: The '20180402_case1' is a SharePoint list data srouce within my PowerApps app.

 

I think the formula that you provided is correct. Please check if the connection to the SharePoint list data source is invalid within your PowerApps app, if yes, please update the connection to the SharePoint list data source.

 

You could also consider Refresh the SharePoint list data source within your PowerApps app to check if the new added records shown up within your Gallery control.

 

In addition, please consider take a try to re-create your PowerApps app or re-add the SharePoint list data source, then try it again to check if the issue is solved.

 

Best regards,

Kris

 

 

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
UserInterface7
Level: Powered On

Re: Powerapp stopped displaying results.

Yes, it's a SharePoint list. I tried refreshing the data and also republishing the app. What I find strange is that it was working fine for about 4 months. It's just that it lost mobile connection while running the collect function.

 

My app is basically laid out in the same format as yours. I'm not exactly sure what you want to see, but as I mentioned nothing within the app itself is different and it can connect to the data source as its still running the collect function on the SharePoint list.

Its just no longer displaying the items in my app. It's like the app is not recognising that any items were created today in the SharePoint list. I feel like it would be a stuck command somewhere except that it still allows me to create more items in the SharePoint list.

 

I also tried adding =true to my formula but same results.

 

app.PNGsplist.PNG

(15 created today as I ran the collect function and it created them) but can't see them in the mobile app or in the webapp

 

info.PNG

webapp.PNG 

Happy to provide more info, just not sure what else you would need to see to help me.

UserInterface7
Level: Powered On

Re: Powerapp stopped displaying results.

Does anyone else have any ideas? I don't want to have to copy over everything into a new app if I can avoid it...

Aaron_Kapala
Level: Powered On

Re: Powerapp stopped displaying results.

I have a similar problem with my App. My team and I log our time on there for different projects, all working fine with no issues then last week all of a sudden it stops functioning correctly. i made no chances to the app, it was working fine. now the time lof their time in the app and the data goes back to our excel data sheet yet that information will not display in the app, it only displays up to the 12th April. also the date was working properly but now records it as the day before they are logging it. the only thing i can see that has happened is an update from PowerApps, there is no other reason i can find of it not working properly!

 

really need help with this, again i don’t want to re-build an app that was working fine!

UserInterface7
Level: Powered On

Re: Powerapp stopped displaying results.

Thats interesting.. I might copy into a new app and see what happens.

UserInterface7
Level: Powered On

Re: Powerapp stopped displaying results.

So even when copied into a new application it still doesn't work. I think that the connector for SharePoint has changed as i don't remember it asking about selecting the type before (OnPrem/o365).

 

Still strange because mine crapped out halfway through the collect function and then didn't display any new ones in the gallery after that.

 

Would this error have anything to do with the issue?

 

function.png

If I leave the gallery at its default, it shows all items fine. It just seems to be that the sort or filter is not working anymore. wide.PNG

 Old app on left, new app on right.

 

 This works as expected, only showing entries that match '8.12 '

SortByColumns(Filter('Zoom Room Checklist', title=8.12), "Title",Descending) 

 

Tried this but it fails (probably wrong syntax though)

SortByColumns(Filter('Zoom Room Checklist', created=24/04/2018), "Title",Descending) 

Helpful resources

Announcements
thirdimage

Coming Soon: T-Shirt Design Contest

Keep your eyes open for our upcoming T-shirt design contest!

thirdimage

Power Apps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

Top Solution Authors
Top Kudoed Authors
Users online (6,169)