cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Maxwell123
Helper II
Helper II

Powerapps Tenant Migration Issue

Hello, I am moving apps between an environment in one Tenant to and Environment in another. I can move the apps without flows over but any Canvas apps using flows will not import correctly. Below is the error I receive on mostly all the flows. 

 

Flow save failed with code 'DynamicOperationRequestClientFailure' and message 'The dynamic operation request to API 'wordonlinebusiness' operation 'GetFileSchema' failed with status code 'BadRequest'. This may indicate invalid input parameters. Error response: { "status": 400, "message": "The selected file doesn't exist, please select a valid file and drive.\r\nclientRequestId: 0c6d56d8-aa7d-4a20-a264-42e77c91d6b0", "error": { "message": "The selected file doesn't exist, please select a valid file and drive." }, "source": "wordonlinebusiness-wus.azconn-wus-01.p.azurewebsites.net" }'.

 

 

The flows are usually working with Sharepoint lists and document libraries which have not been migrated over yet. Could this be the issue?

 

Maxwell Wendorff

9 REPLIES 9
WarrenBelz
Super User III
Super User III

Hi @Maxwell123 ,

The Word Online (Business) Connector is a Premium Connector requiring a Per User Plan for any user connecting to this app. Does the user you are trying to import this package with have this licence?

 

Please click Accept as solution if my post helped you solve your issue. This will help others find it more readily. It also closes the item. If the content was useful in other ways, please consider giving it Thumbs Up.

Yes, I have a dynamics 365 enterprise edition on each tenant. 

@Maxwell123 ,

Another thought - the Word Merge would use Template which is not present in the new tenant (and if it was, it would be a different document reference). This may be causing the Flow import to fall over.

You may have to import this separately, add the template and then edit the flow to point at the new reference.

 

Please click Accept as solution if my post helped you solve your issue. This will help others find it more readily. It also closes the item. If the content was useful in other ways, please consider giving it Thumbs Up.

Hi @Maxwell123 ,

Just checking if you got the result you were looking for on this thread. Happy to help further if not.

Please click Accept as solution if my post helped you solve your issue. This will help others find it more readily. It also closes the item. If the content was useful in other ways, please consider giving it Thumbs Up.

So sorry for the delay, it has been a busy week with a migration going on here. I edit the definition file (definition.json) and change the sharpoint site URL to the new tenant. The sharepoint site on the other tenant is identical to the old all it has different is a new URL. Is there anywhere else I would need to make changes in the flow file? When I finish editing the file I save it and recompress the file as a zip but get an unknown error when importing

Hi @Maxwell123 ,

You might consider posting that at the Power Automate Community as they would have a better idea on that.

 

Please click Accept as solution if my post helped you solve your issue. This will help others find it more readily. It also closes the item. If the content was useful in other ways, please consider giving it Thumbs Up.

365-Assist
Advocate II
Advocate II

Hi Maxwell,

 

Did you get a solution for this? I have the same scenario and same issue.

 

Darren Lutchner

I figured out an easy way to get thing to work!!!

 

Import the powerapps into the new tenant but using your old credentials as a connection! 

 

In my example most of my projects had flows and a powerapp. I imported them both into the new tenant and then removed the data source from the powerapps and added the new data source back in right away. 

 

Then i went to flow and changed the data source locations over to the new tenant and was able to get everything working without rebuilding anything. 

I am about to leave work which Is why this response was written vaguely so If you need more explanation I can do so with photos and a step by step process!

 

I can help you get this figured out!!!!!

Thanks for the reply.

 

Were you exporting/impoting as PowerApp Solution or just individual PowerApps? I need to do it a s a Solution so not sure how your work around will work as you are not given the option to use the old credentials in a Solution.

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

secondImage

Demo Extravaganza is Back!

We are excited to announce that Demo Extravaganza for 2021 has started!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Top Solution Authors
Top Kudoed Authors
Users online (27,854)