cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
DM_110
Level: Powered On

Powerapps browsegallery not seeing data source

I created a powerapp that is linked to a data source which was working fine for over a year. However, three weeks ago it stopped working. I noticed the browsegallery is not seeing the data source. The details form and edit form see the data source with no problem. It's just the browsegallery is not seeing the data source. I've tried refreshing the data source which it does successfully. I've also tried removing the data source and add it back and that doesn't help. I've tried publishing an older version of the app and that didn't help as well. I'm at a lost as to why the browsegallery will not see the data source in the Properties drop down selection?

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
DM_110
Level: Powered On

Re: Powerapps browsegallery not seeing data source

I ended up just building a new app from scratch and now I have no problem. Thank you all for your suggestions.

View solution in original post

17 REPLIES 17
Dual Super User
Dual Super User

Re: Powerapps browsegallery not seeing data source

Are you tieing directly to the datasource?  Or are you using some filter, sort and search functions to manipulate the datasource?  How does your Items property read?



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.
DM_110
Level: Powered On

Re: Powerapps browsegallery not seeing data source

I am using filter, sort and search functions.

Highlighted
Dual Super User
Dual Super User

Re: Powerapps browsegallery not seeing data source

I would go back and review your Items statement.  It could be that your datasource has gotten large enough that you are having delegation issues or it could just be changes in the way the Filter, sort and search functions you are using work behind the scenes. As new features are released it can make subtle changes to the way things interoperate.  That may have caused the issue you are seeing.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.
cwebb365
Level 10

Re: Powerapps browsegallery not seeing data source

I had this same issue with a few of my apps recently just randomly stopped loading some galleries as well. If I remember correctly powerapps stopped recognizing a Boolean stand alone value and I had to update it to statically compared it.

What I mean is I had a filter that was like filter(datasource, columnA = variable && Booleancolumn) where booleancolumn was a Boolean value from the datasource. Which would only return values where that bookeancolumn was true. It stopped working and I had to just call it out and it fixed it. No error nothing. Just had to find it.
Filter(datasource, columnA = variable && booleancolumn = true)

Anyway might not be same issue but happened on two of my apps. Was tricky because no errors just wasn’t returning data randomly anymore ;).
DM_110
Level: Powered On

Re: Powerapps browsegallery not seeing data source

I am such a novice with powerapps.  Below is my formula that used to work with no problem for my browsegallery.  Where would I put a "=true"?

 

SortByColumns(Filter('GTA West Node Database',StartsWith(RTN_x0020_Node_x0020_Seg, TextSearchBox1.Text)), "RTN_x0020_Node_x0020_Seg", If(SortDescending1, Descending, Ascending))

cwebb365
Level 10

Re: Powerapps browsegallery not seeing data source

Near the end. if( sortdecending1 = true,
DM_110
Level: Powered On

Re: Powerapps browsegallery not seeing data source

I tried it, but still no luck.  I refreshed the datasource as well.

 

SortByColumns(Filter('GTA West Node Database',StartsWith(RTN_x0020_Node_x0020_Seg, TextSearchBox1.Text)), "RTN_x0020_Node_x0020_Seg", If(SortDescending1=true, Descending, Ascending))

cwebb365
Level 10

Re: Powerapps browsegallery not seeing data source

What happens if you put a double quotes in place of the text box? Space or perhaps a word” that you know exist in the data source
DM_110
Level: Powered On

Re: Powerapps browsegallery not seeing data source

"double quotes in place of the text box? Space or perhaps a word” that you know exist in the data source " - i tried but still no luck.

 

In total I have 4 apps that are indentical, the only difference is the datasource that they are pointed to.  Two of them work fine and 2 have stopped working.  The 4 data source are the same excel template file, but each file just has different data entry in them.  The column headings are all the same across all 4 data source files.

 

If I change the data source file in one of the apps that is not currently working to use another data source, the app works.

Helpful resources

Announcements
thirdimage

Power Apps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

SecondImage

Difinity Conference

The largest Power BI, Power Platform, and Data conference in New Zealand

Top Kudoed Authors (Last 30 Days)
Users online (4,125)