cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

Powerapps custom form - SharePoint list not point to list but a view that doesn't exist.

So i have a powerapp custom form for a sharepoint list, that points to a view that doesn't exist instead of the list itself.  I cannot find a way to change it.  On top of that the forms no longer work.  Any suggestions on how to fix this?

3 REPLIES 3
Highlighted
Continued Contributor
Continued Contributor

Re: Powerapps custom form - SharePoint list not point to list but a view that doesn't exist.

Hi @ddd29

 

If you have a form that points to the wrong place the best idea is to remove and recreate.

 

https://docs.microsoft.com/en-us/powerapps/maker/canvas-apps/customize-list-form#use-the-default-form

 

Following the above will set the default. And you can click delete following the information after.

 

Thanks,
Nicky

Highlighted
Community Support
Community Support

Re: Powerapps custom form - SharePoint list not point to list but a view that doesn't exist.

Hi @ddd29,

 

Do you have any error message? If you still can customize the Form, please check if the OnEdit property of the SharePointItergration is set to EditForm(FormName).

Capture.PNG

 

Then check the DataSource property of the Form. Make sure it's connected to the list. You can try to reconnect the data source to have a test.

 

In addition, you could try:

Clear your cache--it's possible it's running on old cache

Try another browser to see if it's a browser issue

Sign out and sign back in--it can be a credentialing issue

 

Regards,

Mona

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Frequent Visitor

Re: Powerapps custom form - SharePoint list not point to list but a view that doesn't exist.

So, the forms are working again, very slowly though the whole sharepoint site is pretty slow.  

The form is pointing to  sharepoint.site\team\list\foobar.aspx
The foobar.aspx view no longer is part of the site.  Though when i click customize for the forms, the sharepoint.site\team\list\foobar.aspx is the url it shows.  

The forms not showing up earlier, i believe was a cacheing issue, and has sinc started working again.  Do i really have to remake the forms from scratch just to fix the url its pointing to?

Helpful resources

Announcements
August 2020 Community Challenge: Can You Solve These?

August 2020 Community Challenge: Can You Solve These?

We're excited to announce our first cross-community 'Can You Solve These?' challenge!

secondImage

Return to Workplace

Reopen responsibly, monitor intelligently, and protect continuously with solutions for a safer work environment.

secondImage

Super Users Coming in August

We are excited for the next Super User season.

secondImage

Community User Group Member Badges

FIll out a quick form to claim your community user group member badge today!

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors
Users online (4,094)