cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Helper I
Helper I

Powerapps formula fields are all greyed out I can do anything

Hi 🙂

I have recenlty come to face this problem .. I have an app in development and it was working completely fine until it stopped.


I wait for the App to load completely in the browser (the three dots on the browser are gone meaning loading is completed) and then it doesn't matter which property i select for any item on the screen (buttons/gallery/labels, checkboxes etc) the formula input field is greyed out .. I can't do ANYTHING in the app ..

The live app is working the way it is supposed to .. pulls info just fine 

I read a similar post in the forum but there wasn't any working solution .. it just said wait for the app to load completely and i have done that.


Please help out in figuring what to do next  

Thanks,

9 REPLIES 9
Super User III
Super User III

Some ideas:

Did you try opening this app on another computer yet?

Have you tried saving, closing then republishing the app?

Also, do you make backup export ZIP files? Can you import a backup file into a new app? Or you can you export right now and reimport into a new app?

Hi @mdevaney 

Yes to all 3 suggestions ..

Sadly the problem still exists ..

I tried my other apps and they all are fine .. it is just this app that i can't edit anything at all

Thanks for your fast response I appreciate it 🙂

@VeraRizvi
Have you tried clearing your browser of all cookies/history and reopening the app?
Have you tried in another browser (Chrome, Firefox,Edge)?

yes i did all that .. its the same on Edge as well .. that was the first thing I tried


@VeraRizvi
Do you use PowerApps Studio Web version or do you use Desktop?

I use web version and chrome is the browser I am using.

@VeraRizvi
It may be time to open a support ticket with Microsoft

https://powerapps.microsoft.com/en-us/support/pro/

—-
Please Accept as Solution if this post answered your question so others may find it more quickly. If you found this post helpful consider giving it a Thumbs Up!

Did that too an hour ago 🙂

hopefully they will respond soon !

I appreciate your help! Thanks!

Hi - did you ever get an answer or a solution to this issue?  I have the same issue and no matter what I do I cannot get the app back to an editable state (exporting, restoring old version, etc).  It is bizarre that this is happening with restored versions from months ago, long before this error every occurred - leads me to believe this must be something to do with a changed authoring version or somthing?

 

I had this issue a few months ago and raised a ticket with MS - after a couple of days they were still not able to resolve.  I stumbled upon a solution through trial and error which was to export the app, then import it but to a different tenancy.  Save it, then export and re-import it back into our production tenancy.  That "unlocked" whatever was causing the loop or corruption and I was able to continue. 

 

However, this time, that "workaround" isn't working and I am left with a broken app!  

 

Anyone with any thoughts?

 

 

Helpful resources

Announcements
New Badges

New Solution Badges!

Check out our new profile badges recognizing authored solutions!

New Power Super Users

Congratulations!

We are excited to announce the Power Apps Super Users!

Power Apps Community Call

Power Apps Community Call: February

Did you miss the call? Check out the Power Apps Community Call here.

Microsoft Ignite

Microsoft Ignite

Join digitally, March 2–4, 2021 to explore new tech that's ready to implement. Experience the keynote in mixed reality through AltspaceVR!

Top Solution Authors
Top Kudoed Authors
Users online (17,500)