cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

Powerapps labels and default values disappear

All,

 

I've created a simple app that enables a user to order more parts by entering the quantity of the part number. The app has a form embedded that is connected to an excel spreadsheet. I've got three problems:

 

  1. There are two labels(see PowerApps preview picture) "Part Number" and "Quantity" on the screen. The labels appear in the app preview mode but disappear when the app is opened on a phone or not in preview mode on a computer(see PowerApps Error picture).
  2. Each of the fields has a default value of 0. These default values appear correctly in app preview mode and record correctly when a response is submitted from preview mode but disappear like the labels when the app is opened on a phone or not in preview mode on a computer(see the same pictures).
  3. One of the fields is a date field. In both excel and the powerapp the field is set to a short date. However, the power app generates an hours and minutes selector when the field is added and records the hour and minutes. I don't need the hours and minutes - how can I remove this?

I just need my labels and default values to appear correctly.

 

- Thanks 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Impactful Individual
Impactful Individual

Re: Powerapps labels and default values disappear

To confirm: your intended functionality is to have a heading label for your Form control's data cards?

You appear to have the controls setup correctly. The labels for the 'Headers' would be separate from the Form or it's Data Cards, and should remain visible whenever the Studio is in preview, or when the app is used.

However, a few guesses about your issues:

  1. The behavior varies on your phone/web browser
    1. The app has not been published recently
    2. The version you are seeing in the Studio is different than the latest published version (what phone/web would use)
  2. The defaults are not working for your DataCardValue controls
    1. Same as #1, likely those updates are not published
    2. Otherwise, the Form appears to be setup correctly
  3. Not sure if that Date Picker control is part of the form or separate, either way
    1. You can wrap it's output in a Text function to convert it to a ShortDate value
    2. Ex: Text(DatePicker1.SelectedDate,DateTimeFormat.ShortDate)
    3. This will, however, convert it to a Text value, the Minutes/Seconds is usually a display issue (could you format it differently in Excel, for example, to only show date)

View solution in original post

7 REPLIES 7
Highlighted
Community Champion
Community Champion

Re: Powerapps labels and default values disappear

Hello @HaunSolo ,

I am hoping this is something simple.

Firstly are these labels situated in the gallery or in the header.

Also are they in a card or on a fixed position label.

I think a possibility here looking at your screen shots is that the gallery is higher up and is covering the labels.

 

Please click Accept as solution if my post helped you solve your issue. This will help others find it more readily. It also closes the item. If the content was useful in other ways, please consider giving it Thumbs Up.

Highlighted
Community Support
Community Support

Re: Powerapps labels and default values disappear

Hi @HaunSolo ,

Do you mean that your label display its default value only in preview mode,not in other modes?

I've made a similar test but not met the same problem like your description.

My label could display its default value such as "0" in playing mode.

2134.PNG

 

Here's my label's settings:

Text:  0

Visible: true

Could you show me your label's settings in details?

What's more, I notice your label is inside a gallery.Maybe the settings of the gallery effect the value displaying in the label.

So could you show me the gallery's settings in details?

 

 

Best regards,

Community Support Team _ Phoebe Liu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Frequent Visitor

Re: Powerapps labels and default values disappear

Warren,

 

Thanks for your response. I'm not sure how to determine if the labels are in the gallery or in the header. They are not in a card. 

 

I've attached a photo that shows the form dimensions - you can see from the photo that the form size shouldn't be covering the label. 

 

- Logan 

Highlighted
Frequent Visitor

Re: Powerapps labels and default values disappear

Phoebe,

 

I've attached a photo that demonstrates how I have the default for the fields set. When I first added the fields the equation was based on the parent's default. I unlocked the properties and changed the default to zero.

 

- Logan 

Highlighted
Impactful Individual
Impactful Individual

Re: Powerapps labels and default values disappear

To confirm: your intended functionality is to have a heading label for your Form control's data cards?

You appear to have the controls setup correctly. The labels for the 'Headers' would be separate from the Form or it's Data Cards, and should remain visible whenever the Studio is in preview, or when the app is used.

However, a few guesses about your issues:

  1. The behavior varies on your phone/web browser
    1. The app has not been published recently
    2. The version you are seeing in the Studio is different than the latest published version (what phone/web would use)
  2. The defaults are not working for your DataCardValue controls
    1. Same as #1, likely those updates are not published
    2. Otherwise, the Form appears to be setup correctly
  3. Not sure if that Date Picker control is part of the form or separate, either way
    1. You can wrap it's output in a Text function to convert it to a ShortDate value
    2. Ex: Text(DatePicker1.SelectedDate,DateTimeFormat.ShortDate)
    3. This will, however, convert it to a Text value, the Minutes/Seconds is usually a display issue (could you format it differently in Excel, for example, to only show date)

View solution in original post

Highlighted
Frequent Visitor

Re: Powerapps labels and default values disappear

Both of my issues with the default values and labels were resolved when I published the app. 

Highlighted
New Member

Re: Powerapps labels and default values disappear

Is your issue similar to mine here?  https://powerusers.microsoft.com/t5/Building-Power-Apps/Controls-disappear-during-development/m-p/54...

 

What is your solution to fix it during Dev?

Helpful resources

Announcements
secondImage

Demo-Extravaganza 2020

Check out these cool Power Apps & vote on your favorite!

secondImage

Robotic Process Automation

Let's talk about the solution provided by Microsoft for Robotic Process Automation (RPA)

secondImage

Community Highlights

Check out whats happening in Power Apps

secondImage

Community User Group Member Badges

FIll out a quick form to claim your community user group member badge today!

Top Solution Authors
Top Kudoed Authors
Users online (10,066)