cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Advocate I
Advocate I

Powerapps windows app (windows store) GPS location not updating on Spro3 - suspected bug

Hi there,

 

Think I might have found a bug with the windows store version of powerapps for GPS (on Spro 3 at least).  Just using a simple test button and a label, I find that once the Lat / Long have been retrieved first time they are never updated again until app is re-opened.  Running same app on android phone the gps location updates no problem.  Code I am using:

 

button:

UpdateContext({varGPSLat: Location.Latitude});
UpdateContext({varGPSLong: Location.Longitude})

 

label:

varGPSLat&","&varGPSLong

 

I am making a much more sophisticated app where this bug became apparent during testing, but above test shows issue very clearly, in this case the context variables never change values until app is restarted.

 

I originally tried resetting text boxes, navigating to different screen and returning, toggling location button in win10 notification area etc, but nothing works, once the values are set that is it.

 

Hoping someone can confirm and MS can either fix or provide workaround.  All of our field staff use SPro's so this is a big issue and core function for this app.  Also note that we cannot use web interface app (store ver only) as these are rural areas and the app uses offline local storage caching when internet is not available.  From my understanding offline storage does not work on web based apps.

 

Please help!!!

1 ACCEPTED SOLUTION

Accepted Solutions
Super User III
Super User III

@cloudsurfing 

Have you tried doing an Enable(Location) function in your App?  You can enable or disable certain signals in PowerApps.  Just wondering if you force that to enable if it resolves the problem.

 

I hope this is helpful for you.

_____________________________________________________________________________________
Digging it? - Click on the Thumbs Up. Solved your problem? - Click on Accept as Solution. Others seeking the same answers will be happy you did.
Check out my PowerApps Videos too!

View solution in original post

2 REPLIES 2
Super User III
Super User III

@cloudsurfing 

Have you tried doing an Enable(Location) function in your App?  You can enable or disable certain signals in PowerApps.  Just wondering if you force that to enable if it resolves the problem.

 

I hope this is helpful for you.

_____________________________________________________________________________________
Digging it? - Click on the Thumbs Up. Solved your problem? - Click on Accept as Solution. Others seeking the same answers will be happy you did.
Check out my PowerApps Videos too!

View solution in original post

Yes that works! Thank you very much.

 

It does take 2 to 3 seconds for the location to refresh after re-enabling, but at least I can train users to watch for the refresh before processing a new location entry.  Ideally it should be the same as Android where there is a reasonably constant refresh of the data as one moves around but this will certainly be workable.

 

Thanks again for your help!!!

Helpful resources

Announcements
New Badges

New Solution Badges!

Check out our new profile badges recognizing authored solutions!

New Power Super Users

Congratulations!

We are excited to announce the Power Apps Super Users!

Power Apps Community Call

Power Apps Community Call: February

Did you miss the call? Check out the Power Apps Community Call here.

Microsoft Ignite

Microsoft Ignite

Join digitally, March 2–4, 2021 to explore new tech that's ready to implement. Experience the keynote in mixed reality through AltspaceVR!

Top Solution Authors
Top Kudoed Authors
Users online (70,002)