cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
xecho
Helper I
Helper I

Preview mode not working

Hi,

 

Suddenly today the preview mode for the app is not working, but when I go to the Live mode everything works fine.

 

When selecting buttons nothing works, variables are not set etc.

 

Anyone else having this issue?

 

Thanks,

Bart

14 REPLIES 14
timl
Super User
Super User

@LaelH 

Thanks for your message - which I think summarises very well, the sentiment of those that have been affected by this problem.

I agree that there is room for much improvement, and that communications could be much better. I've been talking to @chass about ways that we can improve this (with the help of the community), so that we can help avoid repetitions of this.

Is this problem affecting the published version of your app? For the preview and design environments, perhaps rolling back the authoring version may help, as I mentioned in @markfleets post:

https://powerusers.microsoft.com/t5/Building-Power-Apps/All-grey-screens-in-Studio-mode-and-no-objec...

If I hear of any developments to the status of this issue, I'll update this thread.

vblease
Frequent Visitor

Hello timl

 

I've posted a response here: https://powerusers.microsoft.com/t5/Building-Power-Apps/Power-Apps-release-3-21023-26-completely-bro...

 

But include below for your reference. I continue to have problems with the DefaultSelectedItems property of multi select comboboxes:

 

-----------------------------------------------------------------------

 

Hi Sridutt,

 

I'm having an issue with multi select combo boxes, it was first reported to me by a colleague on Friday 26th Feb.

I can see in one specific app's versions, the following releases were applied, and the problem continues after the release of 3.21023.28:

 

3.21023.26  25/02
3.21022.27  26/02
3.21023.28 28/02

 

To try and explain,

 

When I load a screen I set the DefaultSelectedItems of a combobox to values stored in the database. The control displays correctly and I can see the highlighted tags of the selected items.

 

The following is pseudocode for my setting the DefaultSelectedItems property:

 

Filter(
'[dbo].[TABLENAME]',
FIELD1 = VARIABLE.ID
).FIELD2

 

If the user clicks a save button on the screen, I write the DefaultSelectedItems back to the database regardless of if the user has manually changed these values.

 

The following is pseudocode for me inserting these values back to a database table:

 

Remove(
'[dbo].[TABLENAME]',
Filter(
'[dbo].[TABLENAME]',
FIELD1 = VARIABLE.ID
)
);

Collect(
'[dbo].[TABLENAME]',
ForAll(
COMBOBOX.SelectedItems,
{
FIELD1: VARIABLE.ID,
FIELD2: COMBOXVALUEFIELD2
}
)
);

 

Up to last week this was working as expected.

 

I now see behaviour whereby the combobox intermittently loses the values saved in DefaultselectedItems when clicking save; the result is no data is written to the database and the next time the screen loads the same combobox is empty (because there is no data to retrieve from the database).

 

Prior to these updates I'd saved a version of an affected app on 12th Feb (3.21021.39) and everything was working fine. I'm testing now after the release of 3.21023.28 and the problem continues.

 

I would appreciate advice how to resolve this please? I have built 2 apps in Power Apps and they are both exhibiting this behaviour.

LaelH
Advocate III
Advocate III

Hi @timl 

Thanks for your support with this. 

 

Yes - the published version of my app is now broken too, which is a MAJOR CONCERN. In the past when Microsoft have done this, it has only impacted Studio Edit and Studio Preview modes. In fact when it started on Thursday last week, it also only impacted Studio (Edit and Preview). So it was not too much of a worry. But since the rollout on Friday night, my published app has been impacted too.  This is totally unacceptable.  I am about to go live with paying clients and I just cannot imagine the legal fallout if something like this bought their operations to a standstill in future. Have I made the right choice selecting the Power Platform for my solution? I wonder?  I hope the answer is "yes" because I have invested far too much of my time and money into this development so far, and I would hate to have to change course at this late stage.

Look forward to any feedback you might get.

Regards

Lael

 

 

Hi @timl 

Some feedback ...

I have to eat some very humble pie. Microsoft contacted me to have a look at the issue, and it was all me - and nothing to do with PowerApps at all. I had somehow lost the X co-ords on my controls which threw everything out of kilter when the app was played. 

So, huge thanks to Carlos Figueira for the call to have a look at the issue, and to @sridutt for making contact and  arrangements.

 

I am back in action and back in love with PowerApps again.

 

@timl  - thanks to you too for playing middle man. Really appreciate it.

 

View solution in original post

timl
Super User
Super User

Hi @LaelH 

Thanks for the update. I'm really pleased that everything is working for you again, and I admire your grace in reporting the cause.

Also, I want to echo the appreciation for @CarlosFigueira and @sridutt for doing such great work in this community.

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Welcome Super Users.jpg

Super User Season 2

Congratulations, the new Super User Season 2 for 2021 has started!

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Users online (1,233)